[HTTP] SSL support is not available in this build in

Problems with the Windows version of XAMPP, questions, comments, and anything related.

[HTTP] SSL support is not available in this build in

Postby djalilayed » 26. June 2008 05:56

HI
I use linux server for programing, but now one of my client use windows, so I install xamppe for windows the latest version, so I have a server. php5 apache and it seam working fine.

I am trying to run a script on it to connect to api (xml )but here the problem:

Fatal error: Uncaught SoapFault exception: [HTTP] SSL support is not available in this build in C:\xampp\htdocs\just\client1.php:810 Stack trace: #0 [internal function]: SoapClient->__doRequest('<?xml version="...', 'https://qa-vafe...', 'http://tempuri....', 1, 0) #1 [internal function]: SoapClient->__call('ExGateway', Array) #2 C:\xampp\htdocs\just\client1.php(810): SoapClient->ExGateway('<?xml version="...') #3 {main} thrown in C:\xampp\htdocs\just\client1.php on line 810


I know ssl is enable if you do https://localhost it work, I tested the script on linux and is working fine. I was googling some said to copy 2 file ssleay32.dll and libeay32 from php folder to windows32, and make sure the extension openssl is loaded in php, with what I did but nothing happen still get the same error message.

So how can enable http ssl supprt in windwos sever runing xamppe, please let me know, I trying for a week now to solve this problem
djalilayed
 
Posts: 6
Joined: 25. June 2008 20:07

Postby Wiedmann » 26. June 2008 10:35

SSL support is not available in this build

I know ssl is enable if you do https://localhost it work ... So how can enable http ssl supprt in windwos sever

The problem is not the server (Apache). The SOAP-Extension in PHP is build without SSL support.
--> The only way to enabling this, is to recompile this extension.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

apaceh

Postby djalilayed » 26. June 2008 11:06

HI
Thank you, do you mean I Need to reinstall php from start, and apache seprate without using xampp, or is there a way do so without uninstall xampp.

Please let me know how to recompile soap without uninstall php, or do I need to install php binary for windows from st art.

Regads
djalilayed
 
Posts: 6
Joined: 25. June 2008 20:07

Postby Wiedmann » 26. June 2008 11:34

--> The only way to enabling this, is to recompile this extension.

An other question:
Is the openssl extension active in your installation? (Maybe it's enought to enabling this too)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

ssl

Postby djalilayed » 26. June 2008 11:37

Yes it's enable in php, I almost enabled all the extension, but nothing happen same problme
djalilayed
 
Posts: 6
Joined: 25. June 2008 20:07

Postby Wiedmann » 26. June 2008 11:52

Yes it's enable in php,

You have verified this with phpinfo()?

I almost enabled all the extension,

Not a good idea, because not all extensions can work.


(My problem at the moment: I don't know how to test this myself. And while reading throught the PHP manual / bugtracker, there should be no problem. Just enabling the soap and openssl extension should be enought)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

thank you

Postby djalilayed » 26. June 2008 11:59

Hi
Thank you for your help, I myself don't understand that also, xampp suppose to install php, apache, mysql, mybe it's xampp problem, now what I did, I download php, apache source files for windows, I install them (I download php with openssl support), and php.ini I enable soap and ssl, and seam working fine for me.

Any case things are working fine now, but it will be better to know what exactly the problem in xampp, it is easy to install server in windows using xampp then install each one alone.

I will try later to install xampp again, and see what will happen

Thank you again
djalilayed
 
Posts: 6
Joined: 25. June 2008 20:07

hi

Postby djalilayed » 26. June 2008 12:28

I installed again xampp, what I notice is when you enable openssl on php

extension = php_openssl.dll

and then you go to to see phpinfo (phpinfo())

it don't show you openssl extension, it show all the enable extension (ex encrypt, mhash) but not openssl

because when I install php and apache seprate I can see on phpinfo that openssl is enableed

do why not in xammp, why phpinfo do not show openssl extension, it is in php.ini, extension = php_openssl.dll
djalilayed
 
Posts: 6
Joined: 25. June 2008 20:07

Postby Wiedmann » 26. June 2008 12:31

when you enable openssl on php "extension = php_openssl.dll" and then you go to to see phpinfo (phpinfo()) it don't show you openssl extension

You are using a wrong "php.ini".

Look in phpinfo() which is the correct one.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

thanks

Postby djalilayed » 26. June 2008 12:54

Hi
You are right my freind, in xampp it seam the php.ini filel is in /apache/bin folder, I was before make change in php folder instead of /apache/bin folder.

Thank you very much, you make my work now easy

Regards
jalil
djalilayed
 
Posts: 6
Joined: 25. June 2008 20:07


Return to XAMPP for Windows

Who is online

Users browsing this forum: hthnightwolf and 64 guests