Getting error at http://localhost/

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Getting error at http://localhost/

Postby hearts2 » 22. June 2008 20:51

I would greatly appreciate if anyone could help me, I'm a newbie and I've searched for 3 hrs for an answer to my problem before posting.

I downloaded and installed xampp for Windows version 1.6.6a using the installer.
I have Windows XP Pro SP2.

It seemed to download fine and I can see the XAMPP Control Panel.
But when I go to http://localhost/, I get the following message:

Active Server Pages error 'ASP 0201'

Invalid Default Script Language

The default script language specified for this application is invalid.

I've uninstalled and reinstalled 2x, but the results are the same.
How can the default script language be invalid if it's for Windows?
This must be a simple mistake, on my part, but I can't figure out what it is.

Thanks in advance.
Posts: 3
Joined: 22. June 2008 20:17
Location: Arizona

Postby Danodemano » 22. June 2008 21:02

To me it would appear as though you have IIS installed and that is actually handling the HTTP request. You need to go to to Control Panel -> Add or Remove Programs -> Add/Remove Windows components, uncheck "Internet Information Services (IIS)" then click next to let the wizard remove IIS. After that is completed, reboot your machine then uninstall and reinstall xampp. This should resolve the issue.

Posts: 31
Joined: 21. September 2007 00:16
Location: Dublin, OH

Postby hearts2 » 22. June 2008 23:22

thanks Dan,

that worked! Yay!

I couldn't install the services for Apache and MySQL directly, but I can access it thru the control panel.

I don't think I would have ever figured that out on my own.

Thanks again!
Posts: 3
Joined: 22. June 2008 20:17
Location: Arizona

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 77 guests