Arggg.. DBG (PHP DEBUGGER) is NOT INSTALLED

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Arggg.. DBG (PHP DEBUGGER) is NOT INSTALLED

Postby figgle_faddle » 12. June 2008 14:19

Hi All.

I hope somebody can help me out, I am beyond fustrated right now. I have been working on this for about 6 hours and I cannot figure it out. I haven't searched these forums completely, but I have search every page I could find about it on google. I will search more on here if people figure I should, but my mind is exhausted.

I am am trying to get debug mode working with Nusphere PhpEd. on the lastest xampp software install 1.6.6a

PhpEd It comes with a dbg-wizard.php script that I have placed at the root.

It tells me this.

I noticed that DBG (PHP DEBUGGER) is NOT INSTALLED on your server localhost.

Your DBG Module is: <PhpED install path>\debugger\server\Windows\x86\php_dbg.dll-5.2.x
To install it, please do the following:

* Copy <PhpED install path>\debugger\server\Windows\x86\php_dbg.dll-5.2.x into c:\server\xampp\php\ext\ on your server localhost. No NEED TO CHANGE THE NAME OF THE MODULE!!
* Add the following lines to c:\server\xampp\apache\bin\php.ini
zend_extension_ts=c:\server\xampp\php\ext\php_dbg.dll-5.2.x
NOTE: this line should appear before any other zend_extension(s)
Note: if debugger module is loaded using this way, please make sure extension=dbg.so (or extension=php_dbg.dll) line is removed or commented out.
[debugger]
debugger.hosts_allow= 127.0.0.1 localhost
debugger.hosts_deny=ALL
debugger.ports=7869, 10000/16
* debugger.hosts_allow has should be in format debugger.hosts_allow= host1 host2 host3, where host1, host2 and host3are host names or IP or network addresses allowed to start debug sessions. If you run debug session through an SSH tunnel , you need to list just one local IP address only (localhost).
* Restart web server (SIG_HUP or httpd reload won't help!)
* Launch phpinfo and check its output. Make sure that one of the topmost headers contains
Zend Engine v1.3.0, Copyright (c) 1998-2003 Zend Technologies with DBG v3.2.7 , (C) 2000, 2007 by Dmitri Dmitrienko


For the life of me I cannot get that to work.

Main things I have tried.

-entering it into many different places in the php.ini file.

-renaming the file in the php.ini to php_dbg.dll

- Commenting out the below lines
zend_extension_ts = "c:\server\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_extension_manager.optimizer_ts = "c:\server\xampp\php\zendOptimizer\lib\Optimizer"
zend_optimizer.enable_loader = 0
zend_optimizer.optimization_level=15
zend_optimizer.license_path =


Those are the main things, I am been tinkering around with a lot of stuff, some can't even remember now.

The only one that seem to even remotely work is if I leave the full name to php_dbg.dll-5.2.x and add it the lines just under the [Zend] section. like this.

[Zend]
zend_extension_ts=c:\server\xampp\php\ext\php_dbg.dll-5.2.x
[debugger]

debugger.hosts_allow= 127.0.0.1 localhost
debugger.hosts_deny=ALL
debugger.ports=7869, 10000/16
zend_extension_ts = "c:\server\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_extension_manager.optimizer_ts = "c:\server\xampp\php\zendOptimizer\lib\Optimizer"
zend_optimizer.enable_loader = 0
zend_optimizer.optimization_level=15
zend_optimizer.license_path =
; Local Variables:
; tab-width: 4
; End:


This code gives me a error.
DBG 3.2.10

Failed to start DBG session


Reason: failed to connect to the client address 127.0.0.1:7869
Not sure what it means? Visit http://www.nusphere.com/dbg/ for troubleshooting.

Debugger request: "LONGNUMBERVALUE-EDITEDOUTBYME;d=1,p=0,c=1"
Request found in: "$_COOKIE['DBGSESSID']"
Target PHP version: "5.2.x"
Server API: "Apache 2.0 Handler"
Extensions API: "220060519"
Modules API: "20060613"
PHP API: "20041225"


In the phpinfo at no time has it ever said Zend Technologies with DBG v3.2.7

I am lost, hope somebody can help me. Can't understand why this would be so hard... maybe been at it to long and my mind is passing right over the solution, I dunno.. HELP PLEASE :)

Cheers
figgle_faddle
 
Posts: 1
Joined: 12. June 2008 13:54

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 57 guests