Mercury Mail - HELP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Mercury Mail - HELP

Postby petunia » 08. June 2008 06:39

Hi,
I have a new install of XAMPP. Everything is working great, except Mercury Mail.

When I start mercury mail my website start page changes to:

"Welcome to localhost
Services available on this server:
Mailing list subscription management services"

It's a Mercury Mail login.

Why is this becoming my home/start page?
How can I stop it?

Are there any good/simple docs that explain the basics of configuring Mercury Mail?

thanks!!
petunia
 
Posts: 1
Joined: 08. June 2008 06:30

Mercury localhost problem fix.

Postby Dieter Gribnitz » 23. October 2008 22:08

Hi, I couldn’t find the answer for this problem on any blogs, thus I figured it out myself.
I have minimum experience with protocols, so feel free to correct me if I am wrong.

Here goes: What happens is, when you start Mercury, it loads certain services into ports.
You can check this with Xampp-portchecker this is the default setup for Mercury.
[HTTP] = port 80, [SMTP] = port 25, [pop3] = port 110, [IMAP] = port 143.
The problem is that Appache also uses port 80 to run you localhost environment.
When you start Mercury, it overrides the Appache service, thus directing you to mercury as localhost
instead of the environment that you have set up in Appache.

Step(1) Open the Xampp ControlPanel Start Mercury and click on Admin.
Step(2) Mercury should now open. Click on Configuration->ProtocolModules.
Step(3) Uncheck MercuryB HTTP web server. Restart Mercury.

Easy as that. Mercury and Appache sould now play nice.



Joomla! and Mercury.

This is a setup tutorial for mercury to work with Joomla! for whoever may need it.
This is how I set up the mail test environment on my pc.

In Mercurys' configuration, Click Manage local Users.
You can create test mail accounts here.
It is Important to add passwords to users for them to function.
Thus.. If you click change on postmaster, you can add a password.
Go to the backend of Joomla! and set it up as follows.
Click on Site->Global configuration. click on server tab.

Mailer = SMTP Server
Mail from = postmaster@localhost.com
SMTP Username = postmaster
SMTP Password = [your password]
SMTP Host = localhost

It should now send files from localhost.
Create a new User in Mercury. lets call the user testserver.
You can now set up your user account in your mail client.
I use thunderbird. This is what your account setup should look like:


Your Name: Jhon Doe
Email Address: testserver@localhost.com

You can Use pop3 but I prefer Imap since it keeps your files separate.
Incoming server: localhost
Incoming username: testserver
Account Name: Test Server

You can now Use your fake mail account on your local testing environment as if your site is online.
This is very useful for offline testing.
I hope this helps someone, since I could find no documentation on it myself.
:D
Dieter Gribnitz
 
Posts: 1
Joined: 23. October 2008 22:04
Location: South Africa

Postby glitzi85 » 24. October 2008 15:26

Hi,

Mercury is providing an own Webserver for the Mailing Lists.

You can change the port of this Server by opening the Mercury Admin Program and then doing this:

In the Menu select Configuration -> MercuryB HTTP Server

Now change the Listen on TCP Port Settings to an unused Port (8080 for example). Maybe you have to restart Mercury. Also you can bind the Mercury HTTP Server to localhost only by putting 127.0.0.1 in the IP Interface Box.

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Mercury localhost problem fix.

Postby pireseder » 18. March 2011 19:38

Dieter Gribnitz wrote:Hi, I couldn’t find the answer for this problem on any blogs, thus I figured it out myself.
I have minimum experience with protocols, so feel free to correct me if I am wrong.

Here goes: What happens is, when you start Mercury, it loads certain services into ports.
You can check this with Xampp-portchecker this is the default setup for Mercury.
[HTTP] = port 80, [SMTP] = port 25, [pop3] = port 110, [IMAP] = port 143.
The problem is that Appache also uses port 80 to run you localhost environment.
When you start Mercury, it overrides the Appache service, thus directing you to mercury as localhost
instead of the environment that you have set up in Appache.

Step(1) Open the Xampp ControlPanel Start Mercury and click on Admin.
Step(2) Mercury should now open. Click on Configuration->ProtocolModules.
Step(3) Uncheck MercuryB HTTP web server. Restart Mercury.

Easy as that. Mercury and Appache sould now play nice.



Joomla! and Mercury.

This is a setup tutorial for mercury to work with Joomla! for whoever may need it.
This is how I set up the mail test environment on my pc.

In Mercurys' configuration, Click Manage local Users.
You can create test mail accounts here.
It is Important to add passwords to users for them to function.
Thus.. If you click change on postmaster, you can add a password.
Go to the backend of Joomla! and set it up as follows.
Click on Site->Global configuration. click on server tab.

Mailer = SMTP Server
Mail from = postmaster@localhost.com
SMTP Username = postmaster
SMTP Password = [your password]
SMTP Host = localhost

It should now send files from localhost.
Create a new User in Mercury. lets call the user testserver.
You can now set up your user account in your mail client.
I use thunderbird. This is what your account setup should look like:


Your Name: Jhon Doe
Email Address: testserver@localhost.com

You can Use pop3 but I prefer Imap since it keeps your files separate.
Incoming server: localhost
Incoming username: testserver
Account Name: Test Server

You can now Use your fake mail account on your local testing environment as if your site is online.
This is very useful for offline testing.
I hope this helps someone, since I could find no documentation on it myself.
:D


a few years later.... good job sir well done.
pireseder
 
Posts: 1
Joined: 18. March 2011 19:27

Re: Mercury Mail - HELP

Postby mrfdes » 22. March 2011 13:38

I got all this to work with no problem, i ended up with having something like my own internal home email system.

One more thing i would like to know now:
How can i let mercury communicate with the outside world too?

I did alter the line "sendmail_from" in php.ini, but it still gives errors about mail not being delivered (mail outside the local intranet, that is, internal mail works fine):

; For Win32 only.
; http://php.net/sendmail-from
;sendmail_from = postmaster@localhost
sendmail_from = me@myaddress.org.uk (here, I obviously put my real address)
;added the above myself

Is this right how I did it?
If not, where did I go wrong?

thank you in advance.
mrfdes
 
Posts: 5
Joined: 06. March 2011 13:39


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests