Drupal & XAMPP: Failed to connect to mailserver

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Drupal & XAMPP: Failed to connect to mailserver

Postby kggmvmv » 16. May 2008 00:22

This may or may not be more of a Drupal issue than an Apache or XAMPP issue.

I'm running this on WinXP+SP2 on an Athlon 64.
This is one PC among four in my house (family home).
I'm doing this not in order to have web pages
that can be viewed by other members of my household,
but rather to do some Joomla/Drupal/etc prototyping and review
before trying to do real development on a cranky ISP.

A few days ago, I download XAMPP, and installed it without any trouble.
I ran the control panel for it.
I started up Apache.
I started up MySQL,
because I knew that both Joomla and Drupal required it.

I saw no need to start the FileZilla server,
since I can just copy any files I want from one folder to another.

I saw no need to start Mercury mail server,
as I had no intention of sending or receiving mail from my PC,
other than as an SMTP *client* of my borg-like ISP.

Then (yesterday) I downloaded and installed Drupal.
Again, no hitch *installing* it.

However, during its configuration process,
it asks for a couple of email addresses.
One was to use as the "From" address when sending out emails
to confirm new-user registrations;
I forget what the other one was for.
Again, I had no intention of actually having people (even my family)
sign up for my prototype web site,
so I just put in the email address I use on my ISP.
All went well, and I got to the final page, which said:
Drupal installation complete
and then
"Congratulations, Drupal has been successfully installed."
But in between those two were a pair of error messages, saying
Code: Select all
    * warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in D:\Program Files\xampp\htdocs\_drupal\includes\mail.inc on line 193.
    * Unable to send e-mail. Please contact the site admin, if the problem persists.

So, I just started Mercury now, and it put up a sort of log window
with a zillion little message windows inside it.

Does anyone know how I should set up this email thing?
kggmvmv
 
Posts: 8
Joined: 15. May 2008 22:57

Postby ifokkema » 16. May 2008 08:43

Well, by starting it up you're almost done anyway. However, relaying is off standard in XAMPP which means you can't send emails to outside addresses. Fix this by editing c:\xampp\MercuryMail\MERCURY.ini
Under [MercuryS] it says:
Relay : 0
Change this to 1.

If mails don't arrive and stay in the queue (you can see it in the Mercury window) you may need to edit the Nameservers directive in the [MercuryE] section, too.

HTH!

Ivo
ifokkema
 
Posts: 56
Joined: 08. May 2008 13:05
Location: Leiden, Netherlands


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 68 guests