How to reinstall XAMPP?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

How to reinstall XAMPP?

Postby The Lepricon » 13. May 2008 05:42

I can't figure this out. I have tried uninstalling XAMPP using Windows>Control Panel>Programs and Features (I'm running Vista Business BTW) and then rebooting and installing again. Everytime I do this it seems to be reinstalling with a lot of the same parameters.

For instance, I changed the Index.html file for my testing purposes. But, even after a uninstall and reinstall of XAMPP when I click on Apache Admin in the XAMPP Control Panel it brings up my test Index.html. even if I manually delete this file.

For better info, one of the problems I'm having is that php is not working. If I go to XAMPP>htdocs and click on index.php it opens that crazy web page that says "Something is wrong with the XAMPP installation :-(". I've tried everything I can find thru a Google search and finally just decided on a reinstall, but it's not reinstalling fully, or not uninstalling fully.

So, is there not a way to totally uninstall XAMPP?

Any help would be appreciated.
The Lepricon
 
Posts: 7
Joined: 13. May 2008 05:29

Postby xamppnewbie » 13. May 2008 12:47

From my newbie and a single incident experience I can confirm that indeed the xampp uninstall is not perfect. I believe that the main reason is due to the fact that some of its main components run as services in Windows.

The way to completely clean after uninstall is to:
  1. Using Task Manager, kill the processes that are still running (e.g. mercury, mysql, apache, etc.)
  2. Using Adiministrative Tools (Services) disable any remaining service that belongs to xampp (mysql, apache, etc.)
  3. Execute INSTSRV <servicename> REMOVE on any remaining service.

INSTSRV is part of the Windows Resource Kit and can be downloaded from Microsoft.

HTH :-)
xamppnewbie
 
Posts: 12
Joined: 11. May 2008 15:59

Postby markljackson » 10. August 2008 01:55

did you delete the XAMPP directory before the re-install? You should also have rebooted before doing the re-install.

Services are not the problem unless they are not being uninstalled, not likely. (may have to try this, just to find out). Also, you may want to use an erase utility, as Windows may be just reusing the files it finds on your HDD. Vista blows so hard, it's pathetic.

also XAMPP does not install services unless you request it.

OK did the uninstall, and it works fine. Nothing left except the XAMPP directory but that was because it was not empty. The only thing in there is log files. The installer asks if you want to remove your files, and if you don't agree, it leaves them. Reinstalled w/o reboot or wipe, and all is fine. Registry entries left are for the START menu, shell directives (no roam), application event messages, MRU lists. All normal.
markljackson
 
Posts: 3
Joined: 10. August 2008 01:26

Postby dallen » 10. August 2008 02:30

I'm pretty new with xampp but I've already had some problems and read about it at several places. I hope you're not installing xampp in the 'Program Files' folder with Vista. Apparently this doesn't work because of missing or insufficient write permissions in the 'Program files' folder (with Vista).

I did a complete uninstall of xampp yesterday. I went through the registry and deleted anything that referenced my xampp folder. If you opt to do this, be very, very careful! When I reinstalled I used the ZIP version and manually unzipped the files in my xampp folder. This way Windows doesn't make any entries in your registry (or so I'm told).
dallen
 
Posts: 7
Joined: 10. August 2008 01:34


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 36 guests