[Solved] Problems with xampp-win32-1.4.16 on Windows XP SP2

Problems with the Windows version of XAMPP, questions, comments, and anything related.

[Solved] Problems with xampp-win32-1.4.16 on Windows XP SP2

Postby xamppnewbie » 11. May 2008 16:17

I just downloaded XAMPP version 1.4.16 and installed it.

It must be version 1.4.16 (not a newer one) because this is the version that is officially supported by Zen Cart (so please don't ask me to upgrade because the Zen Cart book explicitly states that only version 1.4.16 must be used).

The installation (to C:\server\xampp) seems to have gone OK.

However, the XAMPP Control Panel (version 2.1) shows Apache and MySql as NOT running.

When I click the [Start] button for Apache, the status windows shows:
Busy...
Apache started
but it is still not running (the [Start] button still displays 'Start', not 'Stop'). Why is it not running? How do I make it run?

Interestingly, this problem does not exist with Mercury. Mercury seems to run nicely (there is a turqoise text label 'Running' and the [Start] button changed to [Stop]).

I have no clue how to troubleshoot this problem. Could you please help?

BTW, I noticed an identical problem description in the following thread:

http://community.apachefriends.org/f/viewtopic.php?t=29578

but what worked for that poster (re-installing XAMPP) didn't work for me. In fact, I re-installed XAMPP twice but that didn't help.

I would be glad to provide any further information that is needed to solve this problem.

Thanks!
Last edited by xamppnewbie on 11. May 2008 18:17, edited 1 time in total.
xamppnewbie
 
Posts: 12
Joined: 11. May 2008 15:59

Postby ridgewood » 11. May 2008 16:27

First... run xampp-portcheck.exe in the \xampp folder. Second... if you are running Skype you will have to reconfigure the ports. Third... it you are running IIS then you will have port conflicts. Fourth... if not the first 3, try doing some more searches on the forum... there is a lot of information.
ridgewood
 
Posts: 57
Joined: 10. January 2005 22:02

Postby xamppnewbie » 11. May 2008 16:33

ridgewood wrote:First... run xampp-portcheck.exe in the \xampp folder. Second... if you are running Skype you will have to reconfigure the ports. Third... it you are running IIS then you will have port conflicts. Fourth... if not the first 3, try doing some searches on the forum... there is a lot of information.

Thank you for your quick answer. I did as you said (BTW, I exited the firewall completely to be on the safe side while troubleshooting, so there is no firewall running). Here is what I received:

Code: Select all
Service              Port   Status
==================================
Apache (HTTP)          80   free
Apache (WebDAV)        81   free
Apache (HTTPS)        443   free

MySQL                3306   free

FileZilla (FTP)        21   free
FileZilla (Admin)   14147   free

Mercury (SMTP)         25   free
Mercury (POP3)        110   free
Mercury (IMAP)        143   free


Also, I am not running Skype and I am not running IIS. As for the searches I have already found a recent posting that describes exactly what I am experiencing, but his solution (to re-install XAMPP) didn't work for me. I will continue searching.

If you have additional ideas in the meanwhile I would be grateful.

Thanks!
xamppnewbie
 
Posts: 12
Joined: 11. May 2008 15:59

Postby ridgewood » 11. May 2008 16:40

Does your controller show the services checked on the left side of the control? And if you use your task manager, is there an Apache process running?

In your admin>services for XP is there a service for Apache registered?
ridgewood
 
Posts: 57
Joined: 10. January 2005 22:02

Postby xamppnewbie » 11. May 2008 17:00

ridgewood wrote:Does your controller show the services checked on the left side of the control?
Yes.

ridgewood wrote:And if you use your task manager, is there an Apache process running?
No.

ridgewood wrote:In your admin>services for XP is there a service for Apache registered?
No. (but a mysql service is registered)

I just noticed another similar problem thread:

http://community.apachefriends.org/f/viewtopic.php?t=29489

I will try to start Apache by just double clicking apache.exe in the bin folder (which solved the problem for that poster) and see where it leads...

Update: I just tried that ( double clicking apache.exe) but apache.exe still won't show up in the task manager. It seems that the problem is in attempting to start apache.exe, not really in XAMPP. But how do I proceed?

Thanks again!
xamppnewbie
 
Posts: 12
Joined: 11. May 2008 15:59

Postby xamppnewbie » 11. May 2008 17:09

OK, so I decided to go to the command line... I typed:
C:\server\xampp\apache\bin>Apache.exe -k start

And received:
[Sun May 11 12:05:40 2008] [error] (OS 2)The system cannot find the file specified. : No installed service named "Apache2".

Hmmm... why wasn't that service installed? The XAMPP installer did not indicate any such problem (that I could notice).

:roll:

Update: I tried installing XAMPP again. This time I verified that I noticed the message box that says:
Apache 2 Service was installed successfully! (Ports 80 + 443)

But the problem still persists. :(
xamppnewbie
 
Posts: 12
Joined: 11. May 2008 15:59

Postby ridgewood » 11. May 2008 17:33

ok... I'm running out of 'real time'...(Mothers Day ;) .... so here is a quick work around that may help you out... 1.. make sure that the services for all the apps are un-installed by de-selecting them using the controller. 2...rename your xampp folder to say xampp1 and run the setup.bat in the folder... this should trigger a screen with the 'do you want to do this' and tell it to go ahead... then try to run apache (without services) from the controller... let me know...
ridgewood
 
Posts: 57
Joined: 10. January 2005 22:02

Postby xamppnewbie » 11. May 2008 18:17

ridgewood wrote:ok... I'm running out of 'real time'...(Mothers Day ;) ....

Happy mother's day! (are you the mother or the child? :))

ridgewood wrote:so here is a quick work around that may help you out... 1.. make sure that the services for all the apps are un-installed by de-selecting them using the controller. 2...rename your xampp folder to say xampp1 and run the setup.bat in the folder... this should trigger a screen with the 'do you want to do this' and tell it to go ahead... then try to run apache (without services) from the controller... let me know...

Well, I tried to do as you said (disabled AVGFree in the process since it was identifying phpcli.exe as a virus) but stumbled upon setup.bat, since there is no such file in the entire xampp directory tree. The closest thing I could find was setup_xampp.bat. I ran it and here is what I received:
Configure for server 1.4.16
Configure XAMPP with awk for 'Windows_NT'
Please wait ...
Enable AcceptEx Winsocks v2 support for NT systems DONE!


##### Have fun with ApacheFriends XAMPP! #####


Press any key to continue . . .

Wow! it works! :D :D :D

Thank you so much!!!

(now, as someone who likes to understand problems encountered, I am scratching my head to figure out what all of that means)

Also, I noticed in 'Task Manager' that there are two apache.exe processes running, not one. Is this OK?
xamppnewbie
 
Posts: 12
Joined: 11. May 2008 15:59

Postby ridgewood » 11. May 2008 18:42

Always the child :wink: ... I run a dozen or so test beds across a net with Win2K, XP Pro and a couple of flavors of Vista plus 3 portable configs ... testing 'test beds' for net apps. My bias is that while the 'installer' version is good for folks just getting started, the glitches are the hardest to diagnose because it is usually a glitch not a bug... (or a port conflict or a security app) I suspect in your case it was that the httpd.conf didn't get set up properly in the install process... what you did was force it to reconfigure.

You can go in (make sure there are no services running) and change the name on the folder back to xampp and run the setup_xampp.bat again (sorry for the earlier shorthand) and it should reconfigure again... then you can use the controller to set up the services. or in the alternative, now that you are a pro ;) uninstall the whole thing and go to the xampp archive and get a copy of 1.4.16 in either the zip or 7zip format and unpack it to say; c:\xampp and just create a shortcut on your menu to the controller... install your services and that should be that.
ridgewood
 
Posts: 57
Joined: 10. January 2005 22:02


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 61 guests