PHP5 with XAMPP 1.6.6a - openssl extension not loading

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHP5 with XAMPP 1.6.6a - openssl extension not loading

Postby MindStar » 23. April 2008 10:34

Hi,

I am unable to load the PHP5 openssl extension with XAMPP 1.6.6a.

I have edited the php5.ini file to load the extension, but phpinfo() is reporting that the extension has not loaded.

The Apache OpenSSL extension has loaded and I can access https://localhost/ - but I cannot open an SSL connection from within my PHP application; I want to send email to a remote host via a secure SMTP connection.

I have searched the forums and read the documentation, but I can't figure out why the PHP5 openssl extension is not loading. There is nothing in the error log.

I have tried re-installing XAMPP 1.6.6a, but that didn't fix it either.

TIA,

Mark.
MindStar
 
Posts: 4
Joined: 23. April 2008 10:08
Location: UK

Postby Wiedmann » 23. April 2008 13:56

I have edited the php5.ini file to load the extension,

Look in the output of phpinfo() which is the correct "php.ini".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby MindStar » 23. April 2008 14:19

OK. PHP5 is using the php.ini file for it's configuration.

I've uncommented
Code: Select all
extension=php_openssl.dll
but the module still isn't loading :?

I've also tried enabling the eAccelerator.dll (which I use on my production server) and that isn't loading either :? :?
MindStar
 
Posts: 4
Joined: 23. April 2008 10:08
Location: UK

Postby Wiedmann » 23. April 2008 15:11

You have looked in phpinfo()? What can you read there regarding "php.ini"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby MindStar » 23. April 2008 15:31

D'oh! I must have been editing the wrong php.ini file in UltraEdit :oops:

I checked
Code: Select all
C:\xampp\apache\bin\php.ini
using NotePad and my changes weren't there :shock:

Closed UltraEdit, reopened it, made the changes, saved, restarted Apache and voila; the openssl and eAccelerator modules are loaded!

Thanks for your patience :)
MindStar
 
Posts: 4
Joined: 23. April 2008 10:08
Location: UK


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests