slow pages on localhost with internet connection active

Problems with the Windows version of XAMPP, questions, comments, and anything related.

slow pages on localhost with internet connection active

Postby maxdamage » 16. April 2008 21:38

Hello!

I'm having the following issue. The pages load very slow on localhost whenever I have the Internet connection enabled. If I disable the network connection, the one that gives me internet access (because I have a second one for sharing the internet connection on my other computer) it starts to work just fine.

I'm using Xampp from about 3 years ago, but now it started to drive me crazy this situation because I have a project that must be finished quickly and I'm slowed down by this issue. Also, I need my internet connection active.

I would appreciate a bit of help.
Thanks!
maxdamage
 
Posts: 4
Joined: 16. April 2008 21:20

Postby LooseCannon » 24. April 2008 12:36

Hello and welcome maxdamage.

You're referring to loading pages in your browser?

If so, what address are you using?

I'm guessing it's a DNS related issue, but first, let us know the above please. Warning: I'm no expert with this, just trying to help!
User avatar
LooseCannon
 
Posts: 162
Joined: 18. September 2007 12:07
Location: Hampshire, UK

Postby maxdamage » 24. April 2008 23:00

When I access the pages on my local machine, I'm using
Code: Select all
http://localhost/path_to_file


I noticed that using
Code: Select all
http://127.0.0.1/path_to_file

works faster, but still, not as fast as it should.

I already checked C:\WINDOWS\system32\drivers\etc\hosts and the localhost is correctly assigned to 127.0.0.1

ps: I don't really need experts, just a more experienced adviser.
maxdamage
 
Posts: 4
Joined: 16. April 2008 21:20

Postby LooseCannon » 25. April 2008 09:04

Ok. Hmm...

I've nothing to suggest or query regarding XAMPP itself. The internal/test web sites _are_ being served by XMAPP's Apache, but very slowly. Got to be the network setup...

So, some more queries:

1. XP or Vista? I know virtually nothing about Vista and certainly not enough to help via a forum. I'll assume XP for now.

2. The second connection 'for sharing the internet connection on my other computer' is on an internal network, with it's own ip addresses? The DHCP and DNS settings on that network are what?

3. The 'internet' connection, that slows the web site when active, has DHCP enabled, including DNS servers?

4. How does browsing to external, www sites perform?

5. Your [Start / Settings / Control Panel] Internet Options (Properties) / Connections / LAN Settings has the 'Automatically detect settings' UN-ticked?
User avatar
LooseCannon
 
Posts: 162
Joined: 18. September 2007 12:07
Location: Hampshire, UK

Postby maxdamage » 25. April 2008 15:43

1. XP or Vista? I know virtually nothing about Vista and certainly not enough to help via a forum. I'll assume XP for now.
XP

2. The second connection 'for sharing the internet connection on my other computer' is on an internal network, with it's own ip addresses? The DHCP and DNS settings on that network are what?
Is a private network that i share with my other computer, just to give it internet access. DHCP and DNS for private network are set on auto (I've ran the Windows network setup wizard on both for sharing the connection)

3. The 'internet' connection, that slows the web site when active, has DHCP enabled, including DNS servers?
The connection is manually configured with IP adress provided by the service provider and it also has DNS servers.

4. How does browsing to external, www sites perform?
Well, that depends on many variables (day, hour, etc) but usually is kinda' slow (not dial-up slow, but slow enough). I think that the speed of localhost has something to do with the speed of the internet connection. When the internet connection is slow (badly) the localhost is slower than "normal" (where "normal" = slow :) ).

5. Your [Start / Settings / Control Panel] Internet Options (Properties) / Connections / LAN Settings has the 'Automatically detect settings' UN-ticked?
All check boxes are unchecked.
maxdamage
 
Posts: 4
Joined: 16. April 2008 21:20

Postby LooseCannon » 08. May 2008 17:22

I've not forgotten you maxdamage. I've been re-considering your issue, while hoping someone else might add their input.

Let's consider the connection sharing. I believe it might affect the XAMPP Apache server in that it's a sort of port forwarding service/setup.

Please take a look at your [Start / Settings / Control Panel] Network Connections, right click on the connection that's shared and select properties; select the Advanced tab and press the Settings button for Internet Connection Sharing, which I assume is activated.

What services have been ticked? Another assumption is that the network setup wizard has done this.

I wonder if the Web Server (HTTP) service is ticked and might be getting in the way of XAMPP's Apache.
User avatar
LooseCannon
 
Posts: 162
Joined: 18. September 2007 12:07
Location: Hampshire, UK

Postby maxdamage » 08. May 2008 22:05

There's no ticked checkbox, all of them are clean, including the Web Server (HTTP) one, and yes, you are right, they are all set by the wizard, I've never touched'em.
maxdamage
 
Posts: 4
Joined: 16. April 2008 21:20

Check yor hosts file!?

Postby klipper » 08. May 2008 23:03

Hi,
On my Vista laptop I had troubles with unaccessible or very slow localhost. Using 127.0.0.1 worked very well. I now found out that Vista use native DNS lookup for IPv6. When I changed network.dns.disableIPv6 from false to true in Firefox about:config (change back to IPv4) localhost was working perfect again. I didn't wanted to completly block IPv6 in Firefox. Now I commented out the rule " ::1 localhost " ( #::1 localhost) in the hosts file (only editable with administrator rights).
Now for localhost the IPv4 line "127.0.0.1 localhost" is used and localhost works perfect again.

Hope this help
Klipper
klipper
 
Posts: 5
Joined: 08. May 2008 22:46

Postby LooseCannon » 12. May 2008 11:49

Good point, thanks klipper. XAMPP doesn't like the ::1 in the host file. Sorry, forgot to mention that and it's been mentioned in many other threads..
User avatar
LooseCannon
 
Posts: 162
Joined: 18. September 2007 12:07
Location: Hampshire, UK


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests