phpMyAdmin no longer viewable

Problems with the Windows version of XAMPP, questions, comments, and anything related.

phpMyAdmin no longer viewable

Postby Cristina » 12. April 2008 03:01

Hello Everyone and Guten Abend!

I must warn you I am a newbie. Even pre-newbie if there is such a thing. I know my HTML pretty well and am taking a shot at PHP for the first time.

I've managed to write a few baby scripts, got my phpinfo() page running, etc. But then I tried to write my first MySQL database and it all went pear-shaped.

I think I am confused about administration panels, but the bottom line is I changed my password and when I ran my phpMyAdmin I get an error:

"phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

Error
MySQL said:

Cannot connect: invalid settings."


Now the funny thing is, that I went threw the Dvorski (2007) tutorial on installing and configuring XAMPP and after a few typos, it all worked fine! I can see PHP pages, and it seems I connected with MySQL all right.

I just can't get my phpMyAdmin page to work at all. When I type in http://localhost I just get a Server error! Error 500 page.

I am thinking, I have the Apache and MySQL server running, just can't use the admin tools?

Lastly, in trying to solve this problem, I uninstalled XAMPP then re-installed it (Windows Installation).

Can anyone help me troubleshoot my admin problem? Thanks for reading if you made it this far!

Auf Wiedersehen!

Cris
Cristina
 
Posts: 2
Joined: 12. April 2008 02:50
Location: North Carolina

Postby Wiedmann » 12. April 2008 03:35

When I type in http://localhost I just get a Server error! Error 500 page.

The reason for this error you can see in Apache error log.

MySQL said: Cannot connect: invalid settings.

- Is the XAMPP demopage (--> cd demo) working?
- MySQL is running (--> taskmanager)?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Cristina » 15. April 2008 02:33

Hello Wiedmann,

Thanks for taking the time to read my post. I'll answer your questions backwards...

No, my demopage is not working (downloaded, installed, in the htdocs folder, but when run from localhost I get the Server error 500 message).

My XAMPP Control Panel it shows MySQL running. and lastly, about the error log, from the error.txt log, I can quite see what the error is...aha! It says Invalid file path c: c:\\xampp\\security\\xampp.users

Is there something I can do?

Cris
Cristina
 
Posts: 2
Joined: 12. April 2008 02:50
Location: North Carolina


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 29 guests