a question about installing

Problems with the Windows version of XAMPP, questions, comments, and anything related.

a question about installing

Postby sportsjuana » 11. April 2008 23:22

I was wondering if someone could help me. I am trying to install apache on my C drive and after using the wizard and it seems to install fine but when I try to start mysql and I Get to the part where it says to start mysql and error comes saying mysql service not started.

Anyone know why this is, i use windows vista home and am new to this program. I will let you know that I originally downloaded the zip file and ran it but deleted it from my directory so I was told that uninstalled the program. Not sure. Any help would be great.
sportsjuana
 
Posts: 16
Joined: 11. April 2008 23:10

Postby Wiedmann » 11. April 2008 23:56

Anyone know why this is

No. But maybe your Windows event log knows why.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby sportsjuana » 12. April 2008 00:09

sorry, what should i be looking for in the event log. Should i check if it is running. I'm confused.
sportsjuana
 
Posts: 16
Joined: 11. April 2008 23:10

Postby Wiedmann » 12. April 2008 00:16

what should i be looking for in the event log.

If a service can't start, you see an error message in the event log.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby sportsjuana » 12. April 2008 06:30

Hanging application winmysqladmin.exe, version 1.0.0.0, hang module hungapp, version 0.0.0.0, hang address 0x00000000.

This is what came up on my computer event viewer. What do I do now.
sportsjuana
 
Posts: 16
Joined: 11. April 2008 23:10

Postby sari42 » 12. April 2008 09:08

search this forum for winmysqladmin,
there are several solutions already posted...
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby sportsjuana » 14. April 2008 08:43

Okay, I tried that and now I am even more confused. does anyone know exactly which one I should try. My message didn't seem to match any other questions that were asked. Thanks
sportsjuana
 
Posts: 16
Joined: 11. April 2008 23:10

Postby sari42 » 14. April 2008 09:11

sorry, I didn't have this issue, I just remembered people saying "winmysqladmin is deprecated, remove it from your (auto-)start folder.." or some such. Maybe someone else can be of better help ....
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby sportsjuana » 14. April 2008 11:20

It appears that mysql is already workign on port 3306. Not sure way but is there a way to change this. I'm not familier with how ports work so if anyone knows that would be great.
sportsjuana
 
Posts: 16
Joined: 11. April 2008 23:10

Postby Wiedmann » 14. April 2008 12:47

Not sure way but is there a way to change this.

Change what?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby sportsjuana » 14. April 2008 20:10

Well what I think is happening is that an old copy of mysql is running in port 3306, so how do I get the new version to work on my computer and get rid of the old version. Sorry i am new to this software.
sportsjuana
 
Posts: 16
Joined: 11. April 2008 23:10

Postby sportsjuana » 15. April 2008 04:22

is there any way I can change the port to something else, so the newest version I have installed will work.
sportsjuana
 
Posts: 16
Joined: 11. April 2008 23:10

Postby Wiedmann » 15. April 2008 04:48

what I think is happening is that an old copy of mysql is running in port 3306

Why did you think this?

From what I've read, you have a problem with "winmysqladmin.exe". And like Sari said: Don't use this program.

On the other side:
If a service (like mysqld) can't start, there must be another message in your Windows event log (because winmysqladmin have nothing to do with your mysql server).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby sportsjuana » 15. April 2008 05:12

Because I tried to start mysql using the bat file and the port message is what came up. However on the windows event log, this is what came up:

Hanging application winmysqladmin.exe, version 1.0.0.0, hang module hungapp, version 0.0.0.0, hang address 0x00000000.

So I should just delete winmysqladmin.exe and it will work.
sportsjuana
 
Posts: 16
Joined: 11. April 2008 23:10

Postby Wiedmann » 15. April 2008 05:23

Because I tried to start mysql using the bat file and the port message is what came up.

The exact message?

Of course... if MySQL is allready working (you can't start with the batch, if MySQL allready started as service), what's your problem?

BTW:
In the Windows service manager you can see if the MySQL service is started or not. And also which MySQL is installed as service.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests