mySQL probs

Problems with the Windows version of XAMPP, questions, comments, and anything related.

mySQL probs

Postby squallflight » 22. October 2003 12:53

I'm running Windows 2000 with the latest version of Xampp. I understand that you need my.cnf in C:\ to run mysql on 2000 and still it doesn't work

I have a file in C: called my.cnf and I've gone through mysql_installservice and followed the instructions but still mysql doesnot work.

this is what my.cnf contains:
Code: Select all
# The MySQL client
[client]
#password       = your_password
port            = 3306
socket          =D:/xampp/mysql/mysql.sock

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port            = 3306
socket          = D:/xampp/mysql/mysql.sock
skip-locking
set-variable    = key_buffer=16M
set-variable    = max_allowed_packet=1M
set-variable    = table_cache=64
set-variable    = sort_buffer=512K
set-variable    = net_buffer_length=8K
set-variable    = myisam_sort_buffer_size=8M
log-bin
server-id       = 1

basedir=D:/xampp/mysql
tmpdir=D:/xampp/tmp
datadir=D:/xampp/mysql/data

#bind-address=192.168.1.1
#log-update     = /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#set-variable   = bdb_cache_size=4M
#set-variable   = bdb_max_lock=10000

skip-innodb
# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = D:/xampp/mysql/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = D:/xampp/mysql/
#innodb_log_arch_dir = D:/xampp/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#set-variable = innodb_buffer_pool_size=16M
#set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
#set-variable = innodb_log_file_size=5M
#set-variable = innodb_log_buffer_size=8M
#innodb_flush_log_at_trx_commit=1
#set-variable = innodb_lock_wait_timeout=50

[mysqldump]
quick
set-variable    = max_allowed_packet=16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
set-variable    = key_buffer=20M
set-variable    = sort_buffer=20M
set-variable    = read_buffer=2M
set-variable    = write_buffer=2M

[myisamchk]
set-variable    = key_buffer=20M
set-variable    = sort_buffer=20M
set-variable    = read_buffer=2M
set-variable    = write_buffer=2M

[mysqlhotcopy]
interactive-timeout

[WinMySQLadmin]
Server=D:/xampp/mysql/bin/mysqld-nt.exe


please help
squallflight
 

Postby squallflight » 22. October 2003 12:55

maybe I should also say that XAMPP is installed in D:/xampp/ as that drive has more space
squallflight
 

Postby Kristian Marcroft » 22. October 2003 13:55

Hi,

when you go on Start -> Run -> cmd and call mysql so start via the command shaell, what error appears on the Screen?
What does the mysql log tell you?
You can find it here:
D:/xampp/mysql/bin/
it's called <hostname>.err
Hostname is your Name of the Computer...
Check that, and then post the messages here.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby squallflight » 22. October 2003 14:25

s'ok now, i reinstalled xampp and wrote my.ini in winnt folder and it all works now
this is what the ini file says:
Code: Select all
[mysqld]
datadir=d:\xampp\mysql\data
basedir=d:\xampp\mysql
skip-innodb
[WinMySQLAdmin]
Server=D:/xampp/mysql/bin/mysqld-nt.exe


thanks anyway
squallflight
 

Postby komakoma » 28. January 2005 05:46

it said

InnoDB: Error: unable to create temporary file; errno: 13
komakoma
 
Posts: 3
Joined: 25. January 2005 04:42


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 38 guests