Help!! Apache2 service specific error 1

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Help!! Apache2 service specific error 1

Postby pocean » 28. March 2008 14:53

I have installed XAMPP everything went fine. Apache was installed successfully and was running.

Then I stopped Apache and I could not get it back to work.


I started the Apache batchfile and I got this message:

Apache2: Service is already installed.
Now we Start Apache 2
The Apache 2 service is starting..
The Apache 2 service could not be started.
A service specific error occured: 1.
More help is available by typing NET HELPMSG 3547


Also, if I go to XAMPP, to port checking, I see that the ports that should be used by Apache 2 are free


I am very new in all of this. Could somebody tell me in detail
what is error 1 and what I am supposed to do?

Thanks pocean
pocean
 
Posts: 6
Joined: 28. March 2008 14:30

Postby Wiedmann » 28. March 2008 15:25

I started the Apache batchfile and I got this message:
Apache2: Service is already installed.

That's the batchfile for installing Apache as service.

If you want start Apache, use "apache_start.bat".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby pocean » 28. March 2008 16:05

Thanks! I found the cause of the problem. There was an error on apache\confg\httpd.conf related to the ServerName.
I fixed the problem and Apache is running :)

But, then I got a message from Windows Security Alert telling me that Windows firewall is blocking Mercury.
The program is asking if it should keep blocking Mercury/32 Core or not.

What should I do. Should I keep Mercury blocked or not?
Thanks
Pocean
pocean
 
Posts: 6
Joined: 28. March 2008 14:30

Postby Wiedmann » 28. March 2008 16:44

Did you need Mercury?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby pocean » 28. March 2008 16:52

Yes, I do.

So, I guess your answer will be. Unblock it

Right?
pocean
 
Posts: 6
Joined: 28. March 2008 14:30

Postby Yukan » 30. March 2008 05:32

pocean wrote:Yes, I do.

So, I guess your answer will be. Unblock it

Right?

If you need webmail, then unblock it. if not, you can leave it be.
Yukan
 
Posts: 6
Joined: 29. March 2008 10:36


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 31 guests