PHPmyAdmin does not start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHPmyAdmin does not start

Postby gerger » 25. March 2008 22:17

Previously I worked with phpdev from firepages.au (apache, mysql and php).

This package contained old apache and php4 and the package has not been maintained/upgraded. So I installed the latest xampp.

php.exe and mysql-nt.exe starts but when I start phpmyadmin from the localhost (http://localhost/xampp/index.php) this message appears:
************************************************************
1.20 I receive the error "cannot load MySQL extension, please check PHP Configuration".

To connect to a MySQL server, PHP needs a set of MySQL functions called "MySQL extension". This extension may be part of the PHP distribution (compiled-in), otherwise it needs to be loaded dynamically. Its name is probably mysql.so or php_mysql.dll. phpMyAdmin tried to load the extension but failed.

Usually, the problem is solved by installing a software package called "PHP-MySQL" or something similar.
************************************************************

I dont know where to look for a solution.

Thanks in advance for your help.

Ger
gerger
 
Posts: 5
Joined: 25. March 2008 22:05

Postby Wiedmann » 25. March 2008 23:10

Somewhere around on your pc is an old "php.ini" (from your old installation".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby gerger » 25. March 2008 23:39

I'll check and will rename all php.ini i find outside c:\xampp

Tks and you'll hear tomorrow

Ger
gerger
 
Posts: 5
Joined: 25. March 2008 22:05

Postby gerger » 26. March 2008 21:34

I renamed old php.ini . They were installed on my d: partition

The only ones left are
C:\xampp\apache\bin\php.ini (shortcut in documents and settings)
C:\xampp\apache\bin\php.ini
C:\xampp\php\php.ini
C:\xampp\php\php4\php.ini

After a reboot it still does not work.

Any further suggestions?
gerger
 
Posts: 5
Joined: 25. March 2008 22:05

Postby gerger » 26. March 2008 22:08

PHPINFO tells me that a php.ini is used from the zend studio server I tried in the past.

Where can I change it into c:\xampp


The phpinfo is:
***********************************************************
System Windows NT GER64 5.1 build 2600
Build Date Nov 8 2007 23:18:08
Configure Command cscript /nologo configure.js "--enable-snapshot-build" "--with-gd=shared"
Server API Apache 2.0 Handler
Virtual Directory Support enabled
Configuration File (php.ini) Path C:\WINDOWS
Loaded Configuration File C:\Program Files\Zend\StudioServer\etc\php.ini
PHP API 20041225
PHP Extension 20060613
Zend Extension 220060519
Debug Build no
Thread Safety enabled
Zend Memory Manager enabled
IPv6 Support enabled
Registered PHP Streams php, file, data, http, ftp, compress.zlib
Registered Stream Socket Transports tcp, udp
Registered Stream Filters convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, zlib.*

***********************************************************
gerger
 
Posts: 5
Joined: 25. March 2008 22:05

IT WORKS

Postby gerger » 26. March 2008 22:41

I found in the documentation at php.net a installation FAQ.
Enter the systemvariable named PHPRC with the value c:\xampp\php

At start up the desired php.ini is found

:) :) :D :P
gerger
 
Posts: 5
Joined: 25. March 2008 22:05


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 66 guests