Client does not support authentication protocol requested

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Client does not support authentication protocol requested

Postby mikepetro » 24. March 2008 00:39

Loaded latest version of XAMMP on a Vista box. Did have mysql/php running on it before successfully but uninstalled them both to install XAMMP.

The XAMMP pages work fine but my existing code gives connection errors like the one below.

Warning: mysql_connect() [function.mysql-connect]: Client does not support authentication protocol requested by server; consider upgrading MySQL client in D:\Program Files\xampp\htdocs\public_html\admin\index.php on line 6

Any pointers?
Michael A Petro
mikepetro
 
Posts: 2
Joined: 24. March 2008 00:30

Postby Nobbie » 24. March 2008 00:51

Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Thanks

Postby mikepetro » 24. March 2008 01:31

Thanks, that "old_password" function did it.

Appreciate it.....
Michael A Petro
mikepetro
 
Posts: 2
Joined: 24. March 2008 00:30

Postby sari42 » 24. March 2008 09:47

btw.,
>D:\Program Files\xampp
paths with included spaces might be problematic ...
sari42
 
Posts: 800
Joined: 27. November 2005 18:28


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 71 guests