enable mod_rewrite and now apache won't restart

Problems with the Windows version of XAMPP, questions, comments, and anything related.

enable mod_rewrite and now apache won't restart

Postby Shizzle » 16. March 2008 17:04

I enabled mod_rewrite in the httpd.conf file and then tried to restart but Apache wont restart it just starts then shutsdown. Looked at the system event log and noticed that apache service cant find a listening socket

Code: Select all
EventData

   The Apache service named
   
   reported the following error: >>>
   no listening sockets available, shutting down


and also this event shows up a lot:

Code: Select all
EventData

   The Apache service named
   
   reported the following error: >>>
   (OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80


I have always gotten this issue with XAMPP and mod_rewrite so I never tried to figure it out but now I need to get it working. Any Ideas :?:

I am using XAMPP 1.6.5 and going to update to 1.6.6a however I know that this won't fix the issue cause I have always had this same issue. I am running on localhost until I have all my pages completed then I will upload to a server with a domain name in the near future. Thanks
Shizzle
 
Posts: 11
Joined: 18. April 2005 04:30
Location: Beaverton, OR USA

Postby Wiedmann » 16. March 2008 17:16

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80

XAMPP or an other (web-)server is allready running.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests