images fail to load despite 'Enable..' fix

Problems with the Windows version of XAMPP, questions, comments, and anything related.

images fail to load despite 'Enable..' fix

Postby Joe_Austin » 14. March 2008 22:21

I have a new install of xampp on Winxp sp2.

I have also copied some web pages (that work fine) into the new server directory to do some local testing.

The problem is none of the images referred to in the pages will load. The references are document relative, the pages will load, the links work, the images are there, and I can http directly to them and they will preview in the browser.

But no references to an image in a page (simple html) will load.

I have tried the EnableSendfile offstage /EnableMMAP offstage fix (actually my conf file was already set to conform to the fix instructions. I tried setting the flags 'on' as well ) but it didn't change anything. I did restart apache after each change.

I have also tried the Win32DisableAcceptEx change without luck.

Are there any other solutions that have been found for this?

Thanks,
Joe.
Joe_Austin
 
Posts: 21
Joined: 14. March 2008 21:55

Postby Milligan » 14. March 2008 23:13

Last edited by Milligan on 17. July 2008 05:52, edited 1 time in total.
Milligan
 
Posts: 136
Joined: 03. March 2008 06:23

Postby Joe_Austin » 15. March 2008 00:07

The 2 most common errors in the error log look like this:

[Fri Mar 14 18:56:08 2008] [error] [client 127.0.0.1] File does not exist: E:/server/xampp/htdocs/CFIDE
[Fri Mar 14 18:56:43 2008] [error] [client 127.0.0.1] client denied by server configuration: E:/server/xampp/htdocs/JoeAustinPhotography/images/mamm0639.jpg, referer: http://localhost/JoeAustinPhotography/TMP7ys7vxqt2i.htm


But I'm not quite sure what to make of them. How do you know what to adjust in the server configuration? What is CFIDE?

Thanks.
Joe_Austin
 
Posts: 21
Joined: 14. March 2008 21:55

Postby Milligan » 15. March 2008 00:36

Last edited by Milligan on 17. July 2008 05:53, edited 1 time in total.
Milligan
 
Posts: 136
Joined: 03. March 2008 06:23

Postby Joe_Austin » 15. March 2008 03:07

Milligan, thanks for the help.

I have checked the things you mention.

My "Enable" flags actually are 'off' not 'offstage'

I do use Dreamweaver , and I read the post you linked and the solution you posted there, but I already have 'php-mysql' selected in the test server dialogue.

I also checked for the <?xml version.... line in my .dwt but I don't have it.

I have

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"

as my first line.

I don't have ZoneAlarm and I don't know what Netlimiter is.

However, while working on a DW tutorial for PHP I loaded and defined the sample site for the tutorial under the server and all images in that site work fine. That site is a peer of the non-working site under the /xamp/htdocs folder

I must have something messed up with this site that I copied into the /htdocs folder, but I can't for the life of me see what it is.

Joe.
Joe_Austin
 
Posts: 21
Joined: 14. March 2008 21:55

Postby Milligan » 15. March 2008 04:22

Last edited by Milligan on 17. July 2008 05:53, edited 1 time in total.
Milligan
 
Posts: 136
Joined: 03. March 2008 06:23

Postby Joe_Austin » 15. March 2008 12:29

I wasn't quite sure what to make of your suggestion as I had never used virtual hosts. Keep in mind I'm new at this.

But I did an experiment. I deleted the copied site and began recopying the site back into the server directory one piece at a time. As I copied and tested each piece I realized that images were working until I copied over the files from the root of my site. Then the images stopped working.

Amongst the 6 or so files I noticed a small file I didn't create called .htaccess and opened it. Guess what....

<FilesMatch "\.(gif|jpg)">
SetEnvIf Referer "^$" local_ref=1
SetEnvIfNoCase Referer "^http://(.*)\.joeaustinphotography\.com/" local_ref=1
Order Allow,Deny
Allow from env=local_ref
</FilesMatch>

Just the type of thing you mentioned. I remember now that on the web host for the original site I had opted , on their control panel, to prevent 'hot linking' so that no referer could access my images directly. This must have created the .htaccess file.

All is well and I can now get some sleep.

Milligan, thanks , I've learned alot from this thread. And I will investigate your email suggestions as well.

Joe.
Joe_Austin
 
Posts: 21
Joined: 14. March 2008 21:55


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests