phpmyadmin file import size

Problems with the Windows version of XAMPP, questions, comments, and anything related.

phpmyadmin file import size

Postby colbyt » 08. March 2008 04:05

Xampp for windows (non-installer version).

No matter what I modify in php.ini, I can not seem to raise the allowed import size in phpmyadmin avove 16.???kbi.

Am I not reading or doing something right?

I need to import some large dumps at the local level.


Colbyt
colbyt
 
Posts: 7
Joined: 03. January 2008 16:41
Operating System: windows 7

Postby Wiedmann » 08. March 2008 04:35

I need to import some large dumps at the local level.

Why don't you use the MySQL command line client?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby sari42 » 08. March 2008 16:31

if you need importing via the web you may want to read phpmyadmin/Documentation.html#faq1_16 (try the upload_dir feature and/or "BigDump").

p.s.
make sure to edit apache/bin/php.ini and don't forget to restart the webserver.
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Issue resolved

Postby colbyt » 08. March 2008 17:10

I was fairly frustrated when I posted the message above as I could not import a rather small file (41KB).

While searching for the answer to the question I posted above I found a lot of people experiencing this problem; but, I found no definate answers.

According to the posts I read there are 3 factors that may affect the ability of phpmyadmin to import lagre files. All of them are set in in php.ini. According to one post I read here the post_max_size may need to be larger than the upload_max_filesize The default settings for the Xampp distribution is the same as the defaults and they are:

memory_limit 32M
post_max_size 16M
upload_max_filesize 32M

What I discovered was that changing the values in the php.ini file which is located in the PHP directory had absolutely no affect on the values recognized by phpmyadmin. Maybe there is a glitch in my installation or maybe not. Copying that file to the phpmyadmin also did not work.

When I copied the php.ini file to the main Xampp directory the new values were read and utilized. I had no problem importing I used the following values in the php.ini:
memory_limit 128M
post_max_size 128M
upload_max_filesize 96M

Next I plan to see what values I need to import a really large dump of 401KB. If there is any interest, I will update this thread afterwards.

Colbyt
colbyt
 
Posts: 7
Joined: 03. January 2008 16:41
Operating System: windows 7

Postby colbyt » 08. March 2008 17:13

sari42 wrote:p.s.
make sure to edit apache/bin/php.ini and don't forget to restart the webserver.


I see!

I was editing the wrong php.ini file!

Thanks!
colbyt
 
Posts: 7
Joined: 03. January 2008 16:41
Operating System: windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 81 guests