Weird Error in Perl LWP::Simple module (Architecture error)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Weird Error in Perl LWP::Simple module (Architecture error)

Postby unstablevelocity » 07. March 2008 22:59

I am testing a Perl program that uses the LWP::Simple module and when I run the program, I get:
Code: Select all
Errno architecture (MSWin32-x86-multi-thread-4.0) does not match executable architecture (MSWin32-x86-multi-thread-5.00) at C:/xampp/perl/site/lib/Errno.pm line 11.
Compilation failed in require at C:/xampp/perl/lib/IO/Socket.pm line 17.
BEGIN failed--compilation aborted at C:/xampp/perl/lib/IO/Socket.pm line 17.
Compilation failed in require at C:/xampp/perl/lib/LWP/Simple.pm line 160.


OS is Windows XP SP2
XAMPP version is 1.6.6a
Perl Module is the current add in on XAMPP ( Perl v5.8.8 )

Is this as simple as updating the LWP module or something more intuitive?

Cheers!
unstablevelocity
 
Posts: 1
Joined: 07. March 2008 22:51

Postby allgaeupit » 26. March 2008 10:35

Hey unstablevelocity,

I had the same problem. When you rename the
Code: Select all
C:/xampp/perl/site/lib/Errno.pm

you won't have this problem, because then perl is using
Code: Select all
C:/xampp/perl/lib/Errno.pm

...
Why? There must be a mistake in the first pm-Module, I think....

But perhaps Apachefriends can fix this problem in the next version...
allgaeupit
 
Posts: 3
Joined: 19. July 2006 08:01


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 36 guests