Error when Starting Apache and SQL

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error when Starting Apache and SQL

Postby countrycharm » 07. March 2008 15:20

I have windows XP Pro with sp2 installed. I have followed every detail of these forms and nothing seems to work for me. I don't know if it is with my computer or I'm not doing something right. I'm a newbie when it comes to this kind of thing I guess. The error log is saying this

[Fri Mar 07 09:08:15 2008] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Fri Mar 07 09:08:20 2008] [notice] Apache/2.2.8 (Win32) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5 configured -- resuming normal operations
[Fri Mar 07 09:08:20 2008] [notice] Server built: Jan 18 2008 00:37:19
[Fri Mar 07 09:08:20 2008] [notice] Parent: Created child process 2500
[Fri Mar 07 09:08:21 2008] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Fri Mar 07 09:08:23 2008] [notice] Child 2500: Child process is running
[Fri Mar 07 09:08:23 2008] [notice] Child 2500: Acquired the start mutex.
[Fri Mar 07 09:08:23 2008] [notice] Child 2500: Starting 250 worker threads.
[Fri Mar 07 09:08:23 2008] [notice] Child 2500: Starting thread to listen on port 6060.
[Fri Mar 07 09:08:23 2008] [error] (OS 10038)An operation was attempted on something that is not a socket. : Child 2500: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.
[Fri Mar 07 09:08:23 2008] [error] (OS 10038)An operation was attempted on something that is not a socket. : Child 2500: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.


I don't know what to do . I have disabled window firewall. I am running Comodo firewall and antivirus. I have set the ports in the firewall that part is ok. The antivirus is not interfering with it I don't think so. I don't know what the error log is trying to tell me. I have run this on ports 80 also with the same problems. Any help would be appreciated. Thank you :!:
countrycharm
 
Posts: 5
Joined: 06. March 2008 16:37

Postby Wiedmann » 07. March 2008 15:43

I don't know what to do

countrycharm wrote:[Fri Mar 07 09:08:23 2008] [error] (OS 10038)An operation was attempted on something that is not a socket. : Child 2500: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.

(Add a line with "Win32DisableAcceptEx" to your "httpd.conf".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby countrycharm » 07. March 2008 18:35

(Add a line with "Win32DisableAcceptEx" to your "httpd.conf".


Where do I add this line in httpd. conf. Thank you for helping me. Dis-regard that last commit. The line you have given me to add to httpd.config did the trick. everything works great now, thank you.
Last edited by countrycharm on 07. March 2008 18:44, edited 1 time in total.
countrycharm
 
Posts: 5
Joined: 06. March 2008 16:37

Postby Wiedmann » 07. March 2008 18:38

Add (at the end).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby countrycharm » 07. March 2008 18:44

That was it, thank you again.
countrycharm
 
Posts: 5
Joined: 06. March 2008 16:37


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests