Insanity! - XAMPP & Dreamweaver

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Insanity! - XAMPP & Dreamweaver

Postby August » 27. February 2008 01:11

Hello: :)

For DAYS I’ve tried every possible variation from the below 2 suggested links to get XAMPP/Apache to work with Dreamweaver. I’ve uninstalled and reinstalled. The information from these 2 links should have worked for my site to come up, but it does. This is so frustrating and it is crazy-making. I’m using DW 8.0.2 and Apache 2.2, using Windows Professional XP, SP2.

http://forums.whirlpool.net.au/forum-replies.cfm?t=569991#r20

http://foundationphp.com/tutorials/apache22_vhosts.php

In Boss’ suggestion it does sound reasonable to use the Directory location but the problem is that Apache won’t take it because it doesn’t allow multiple directory listings for some reason. Maybe if I can get that to work (but don’t know where to allow the command) things might work. Quite often, though, after I fix one problem another one arises.

Right now, I get Error 404 – Object not found.

My httpd-vhost looks like this which is the last thing I’ve settled on (I removed the Allow, deny, etc that was suggested because Apache wouldn’t take the commands for some reason):

<VirtualHost *:80>
ServerName mysite
DocumentRoot C:/vhosts
IndexOptions +FancyIndexing NameWidth=*
Options Includes FollowSymLinks Indexes
</VirtualHost>

<VirtualHost *:80>
ServerName localhost
DocumentRoot C:/xampp
IndexOptions +FancyIndexing NameWidth=*
Options Includes FollowSymLinks Indexes
</VirtualHost>

In DW, I can put in for the testing server https://vhosts or https://mysite or localhost – in Test mode it links fine -- when going to the browser the page comes up with the error. In the browser it looks like this:

https://vhosts/index2.php or whatever name,

Below 404 there is a link on the site name and it brings up the XAMPP sample page just fine... but, on the sample page the browser reads like this:
https://vhosts/xampp/

On rare occasions I don’t get Error 404, but a message:
“Unable to connect
Firefox can't establish a connection to the server at vhosts.”

One other thing, I don’t know if this make any difference or not, but I’ve tried to use https://127.0.0.1 and it doesn’t seem to function, expect for on XAMPP’s sample pages.

Before I go completely crazy does anyone have any suggestions to how I can see my site on my computer? I don’t understand why one of the variations from the above 2 links didn’t work as suggested. I really need this because I’m expanding my site and changed all my extensions from html to php.

Thank you all for you help.
August
 
Posts: 15
Joined: 27. February 2008 00:42

Postby LooseCannon » 05. March 2008 14:16

Just a thought, but are you aware that DW uses scripts to simulate the database connection for the 'test' server? Have a look at the _mmServerScripts directory that DW creates.

I guess the connection info in there might conflict with some XAMPP settings.
User avatar
LooseCannon
 
Posts: 162
Joined: 18. September 2007 12:07
Location: Hampshire, UK

Postby terry » 05. March 2008 18:19

have you tried to set doc root in php.ini ? The one to use is in Apache/bin
Still Trying !!
terry
 
Posts: 18
Joined: 21. September 2006 11:29
Location: Southampton U.K.

Postby August » 06. March 2008 19:50

Hello:

Thank you both for your replies.

Can you please be a bit more specific. I'm limited in my knowledge and not sure what I'm suppose to do with DW in terms of the php.ini file and the _mmserverScripts.

Thanks!
August
 
Posts: 15
Joined: 27. February 2008 00:42

Postby Milligan » 07. March 2008 11:49

Last edited by Milligan on 17. July 2008 06:21, edited 1 time in total.
Milligan
 
Posts: 136
Joined: 03. March 2008 06:23

Postby August » 07. March 2008 20:50

Hello:

Thank you for your reply. Believe or not, I did have a Directory Directive -- and I've tried many things -- what I showed was something that I settled with before making a post entry.

Honestly, I tried all the suggestions. I will once again reconfigure exactly as suggested. In my opinion, this shouldn't be a big thing but it has turned out to be. :cry:

Thanks and I'll keep everyone up-to-date.
August
 
Posts: 15
Joined: 27. February 2008 00:42

Postby August » 09. March 2008 21:14

Hello Again:

In the Error log CFIDE is still showing up for some reason, but, it looks like “something” is trying to happen.

Here’s what DW says:

HTTP error 404 (file not found) occurred while attempting request to the file http://vhosts/index_sxy0vxg19l.php from the testing server.

Here are some possible reasons for the error:

1. Files in “C:/Documents and Settings/…../site/” folder that have the “.php” file extension are not being executed by the testing server.
2. The “C:/Documents and Settings/…./site/” folder does not map to the http://vhosts URL on the testing server. Verify that the URL Prefix maps to the root of your site.



In DW set-up:

Local Info:
Site Name: MySite
Location Root Folder: C:\My Documents
Links relative to: _X_ Document ____Site Root
HTTP Address: http://mysite


Testing Server:

Server Mode: PHP MySQL
Access: Local/Network
Test Server files: C:\My Documents
URL Prefix: http://mysite

Enabled Refresh Files and Cache are ticked.




FYI: Right now the XAMPP test page doesn’t come up at all as it had done before. It doesn’t matter if I use http://localhost, http://vhosts or http://mysite . The 404 page comes up in all instances. When clicking on the site name on that page, the backend page or list of files show up.

Any brilliant suggestions on how to fix this?
August
 
Posts: 15
Joined: 27. February 2008 00:42

Postby sari42 » 09. March 2008 22:10

folders with embedded spaces may be problematic - better install php (xampp) in c:\
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby August » 09. March 2008 22:18

:?: - I'm not sure I get what you're referring to. The document path above is required by Dreamweaver in order to function. Earlier it was suggested that I didn't have the correct functions for DW to work and I have show above within DW what was done for testing for those who had doubts.

My set-up in Xampp within httpd-vhost is exactly as the above poster suggested.

Xampp is installed on the C:/ drive
August
 
Posts: 15
Joined: 27. February 2008 00:42

Postby caspian1 » 10. March 2008 13:35

Hello August,

This may help...
1. Disable Skype (port 80 conflict, port 443 conflict)
2. "Put" DW site in the HTDOCS folder when loading to testserver. (If you are not in HTDOCS you will not be able to browser access the files through the server - that's been my experience)
3. 127.0.0.1 will send you to the XAMPP index page whether you http or https.

Saw your post. I am also a noob and just installed XAMPP tonight. I have issues with the Mercury Mail Server (which I'll place in another post - I've been up all night trying to figure out Mercury - the documentation is awful). Please pardon, if my jargon is off, but if this solution works for you at all it only takes a second.

I initially had a problem with getting the APACHE part right - but that was a matter of getting folder properly identified. I might not be able help much, but at least I won't beat you up - this can be frustrating.

If your server is working (and your firewall is not getting in the way) you should be able to configure straight away in DW (I have CS3 so it may be a little different for you).

(During the install process I used XAMPP as the install folder name for my local host)

Recommendations:
Make sure you have the most recent stable version of XAMPP. Install it and make sure all the programs work in the control center.

Make Sure You Disable Skype (if you are a skype user). Skype and APACHE both uses Port 80 and Port 443.
You don't want to have an immediate conflict with the Web Server. If you have any other software that is using port 80 disable it while you setup the server, to rule that software out as a conflict.

Make sure you have identified the correct ("HTDOCS") folder for your testing server:
Code: Select all
[b]C:\xampp\htdocs\4leads_v1\[/b]

All your websdocs should go in HTDOCS...
You can store your working files ina completely independent folder.

I actually used the same folder for my remote server (because I am not ready to publish anyway)

My URL Prefix is:
Code: Select all
http://localhost/


Here's a XAMPP setup video: 13 minutes
http://video.google.com/videoplay?docid=4139947037335336125
It also covers JOOMLA - watch the JOOMLA portion because it will reveal a couple thing you should think about with Dreamweaver.

I'm a newb too, but this is what I found worked for me. I have not set myself up as a virtually host for a dummy server, because it is not essential to test the functionality of my particular site.

Let me know if this helps...
Anything this hard to learn... has to be worth learning!

Caspian1
User avatar
caspian1
 
Posts: 5
Joined: 10. March 2008 12:43

Postby caspian1 » 10. March 2008 14:02

One more note:

If you install the way posted above, make sure that you attempt to access your site through the browser with the correct URL.

http://localhost/yourwebsite/

This may work for you and allow you to test your site while you deal with the vhost issue and deal with possible port conflicts, etc... You may want to do this to rule out other possible problems and issues.

I visited the link you posted and will try that approach after I deal with my mail server issue.

Good luck, let me know how it goes...
User avatar
caspian1
 
Posts: 5
Joined: 10. March 2008 12:43

Postby August » 10. March 2008 20:28

Hello:

Thank you so much for your input.

I also found this recent post exchange on that was helpful too -- I'm up and running!!! Did you see this on virtual hosting?

http://community.apachefriends.org/f/viewtopi ... ight=vhost


Thank you everyone for your kindness, patience and guidance! :)
August
 
Posts: 15
Joined: 27. February 2008 00:42

Postby caspian1 » 10. March 2008 20:53

No, I hadn't seen that post, but I'm glad I have now. It's the most extensive one I've seen on the subject.

Did the vhost solution work for you, then?

I am going to hold off before trying the vhost. I need to find a work around for the Mercury Mail.

My ISP blocks Port 25, so I'm not sure if the mail server is setup properly because my ISP may be blocking it from sending. If you happen to come a cross a post on that subject (Port 25 -- any kind of workaround) please let me know.

I need to figure out a way to test the email behavior on Mercury/32.
User avatar
caspian1
 
Posts: 5
Joined: 10. March 2008 12:43

Postby August » 10. March 2008 21:03

On this forum, it is the most extensive guidance for setting up Vhost that I've seen too. I used it along with additional input and help. Vhost is working for me now. Although this was long and frustrating, the efforts were worth the trouble.

Good luck and wishing you well.
August
 
Posts: 15
Joined: 27. February 2008 00:42


Return to XAMPP for Windows

Who is online

Users browsing this forum: hthnightwolf and 66 guests