PHP6 add-on or guide?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHP6 add-on or guide?

Postby Sean-Michael » 23. February 2008 17:34

Is there any addons or tutorials/guides to getting php6 working with xampp?

Thanks in advance!
Sean-Michael
Sean-Michael
 
Posts: 69
Joined: 17. September 2006 01:37

Re: PHP6 add-on or guide?

Postby Izzy » 24. February 2008 05:51

Sean-Michael wrote:Is there any addons or tutorials/guides to getting php6 working with xampp?

Thanks in advance!
Sean-Michael

Hello Sean-Michael,
PHP in XAMPP is a compiled module of Apache and IMHO there is no php version add-on that would work.

Normally one has to wait until the developers recompile Apache with a new versions of PHP so all related modules, paths and configuration files will function in harmony - I am not even sure that a stand alone phpv6 would work either as the paths and php.ini files may be in conflict.

You may wish to contact one of the developers for confirmation of this info by using either the forum's PM facility or the Contact page on the Apache Friends web site - either will find one of them and all speak some English.

Usually, when a new stable version of any of the XAMPP modules are released the developers are not far behind.

...and as always, when I express an opinion, I stand to be corrected.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby sari42 » 24. February 2008 11:03

on win it is pretty straight forward if you follow the instructions on php.net:

# For PHP 6 do something like this:
LoadModule php6_module "drive:/pathToXampp(lite)/apache/bin/php6apache2_2.dll"
AddType application/x-httpd-php .php

in apache\conf\extra\httpd-xampp.conf

you need to change the extension dir in apache\bin\php.ini and copy some .dlls to apache\bin as well.

if you want to switch between php5 and php6 you can make the changes in xampplite and just start the wanted apache via ".bat" file:
xampp\apache_start/stop for php5 (or net start/stop apache2.2 if installed as service)
xampplite\apache_start/stop for php6

p.s.
well, I just checked the latest snapshot. I had to
a.) comment all "zend" references
b.) remove all " (double quotes) from the paths (except from the include_path) [bug?]
c.) include_path = ".;D:\xampplite\pear\;"
; php6 needs a trailing ';' after pear !
d.) comment "browscap..."
in php.ini before apache would start....

... but still testing - no guarantees ;)
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby Sean-Michael » 26. February 2008 19:50

Izzy, it so nice to see you still helping around here! I remember all the questions of mine you helped to answer back when I first started using xampp.

If I have time I will write the php mailing list, and ask if anyone there is willing and able to put together something specific for xampp and php6.

sari42, it might sound like nothing is really needed for me to peruse, except for I have a question, could I get a link to your source of information?

This is very nice news to me, I have been hearing that I would need to compile the source, which I haven't any idea at this time how to do it.

Thanks again!
Sean-Michael.
Sean-Michael
 
Posts: 69
Joined: 17. September 2006 01:37


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 49 guests