How to port the existing website on to a network?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

How to port the existing website on to a network?

Postby pmramdas » 23. February 2008 09:49

Dear Friends..

I'm very new to this.. I haven't found any help files for editing the basic httpd.conf and php.ini files.. Thts the reason, i'm writing here..

My problem

I have installed xampp. It is working perfectly fine on http:\\localhost. But my need is to get a access to it from another computer which is in the LAN. It is not happening.. What should i do? I Need,

(1) rather than typing my ip address, the site should appear when i type my website's name. something like, http:\\mysite

What should i do? please help me out....


Thanks in advance
pmramdas
 
Posts: 3
Joined: 21. February 2008 05:35
Location: Kochi

Postby Wiedmann » 23. February 2008 11:20

But my need is to get a access to it from another computer which is in the LAN. It is not happening..

Why not? (error message in your browser)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby pmramdas » 23. February 2008 18:22

The error, Website not found.. But it is perfectly working fine in localhost. What to do? i heard that, some changes to be done with hosts and php.ini files.. is it? if yes, tell me how to do.. plzzzzzzzzzzz
pmramdas
 
Posts: 3
Joined: 21. February 2008 05:35
Location: Kochi

Postby Wiedmann » 23. February 2008 18:34

But it is perfectly working fine in localhost.

You mean with "http://localhost/" als is working.

The error, Website not found..

Well, maybe you are using a wrong hostname/ip or a firewall is blocking the connection.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Sean-Michael » 23. February 2008 18:58

This is being run over a LAN(Local Area Network)? So there is no out side connections being made by the rest of the world? You information is a little confusing to me...

You are hosting a live site?

Have a registered domain name?

You sure there are no firewalls at work blocking?
Sean-Michael
 
Posts: 69
Joined: 17. September 2006 01:37

Postby pmramdas » 24. February 2008 01:33

See.. my site is need to be work within the LAN only. its my company's INTRANET. It doesnt have any connection with outside or Internet.

I installed on a windows XP machine. When i'm typing http:\\localhost or http:\191.6.21.22(my XP Machine's IP), it works very fine. But the problem starts when i'm trying to access the site from other machine which is in the same LAN.
pmramdas
 
Posts: 3
Joined: 21. February 2008 05:35
Location: Kochi

Postby Sean-Michael » 24. February 2008 04:55

Chances are you have a router or pc firewall blocking your communications? It sounds like you cannot get "http://localhost" to load from any computers on the network? As Wiedmann mentioned this is most likely a firewall issue and should be resolved first. I would start by using the IP address assigned to the host machine from the "router?" and the secondary machine use that ip to connect, "http://ip_address". If you cannot connect this way look to your manual to open up the host machine.

Next, I think you will want to look into virtual Host?
http://httpd.apache.org/docs/2.2/vhosts/

This helping?
Sean-Michael
 
Posts: 69
Joined: 17. September 2006 01:37

Postby LooseCannon » 05. March 2008 14:38

Hello pmramdas

If you just want other PCs inside your LAN to access the web site on your PC, you can amend the hosts files on each and every of the other PCs.

You'll find the file here: C:\WINDOWS\system32\drivers\etc

Make a backup copy of the file.

Note that it's called 'hosts'. That has _no_ suffix. Open with a text editor via a right click or from within the editor and then open file. Ok?

Add a line for your PC's ip [tab] webAddress. Eg:

50.100.150.104 www.yeeharrr.local

For a PC with this line in it's hosts file, type www.yeeharrr.local into the browser's address bar and it'll go to the web server hosted on your PC.

Goodluck. :-)
User avatar
LooseCannon
 
Posts: 162
Joined: 18. September 2007 12:07
Location: Hampshire, UK


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests