PHP files do not process

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHP files do not process

Postby rmpowell01 » 23. February 2008 08:47

I have installed XAMPP with no problems. Apache, MySQL is operating and PHP is set to PHP5. When I try to load any PHP file or HTML file with any PHP code the PHP code is ignored. If I go to the http://localhost and try to run the PHP postscript examples I receive Fatal error and told that the file cannot be located. The files are where they should be. I am totally new to LAMP and trying to learn with three books and two online tutorials, but I first have to get a LAMP system working.

I am running XP Pro service pack 2. I tried doing an individual Apache, MySQL, PHP download and install. When I did this I get similar results. The "LoadModule php5_module C:/php/php5apache2.dll" could never be found no matter what I tried. I have removed all three of these separate programs an now have only XAMPP on my system. Does anyone have any idea how to solve this problem I have spend more than 30 hour trying to find the answer myself. :(
rmpowell01
 
Posts: 3
Joined: 23. February 2008 08:28

Postby Wiedmann » 23. February 2008 11:17

When I try to load any PHP file or HTML file with any PHP code the PHP code is ignored.

The demopage ("http://localhost/xampp/") is not working?
Anything in the "error.log"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Anything in the XAMPP "error.log"?

Postby rmpowell01 » 23. February 2008 18:49

The error log does not appear to be of any assistance. But as a Newbee I am not even sure of that. Here are that last several lines of the error log.

[Fri Feb 22 19:48:26 2008] [notice] Server built: Jan 18 2008 00:37:19
[Fri Feb 22 19:48:26 2008] [notice] Parent: Created child process 2732
[Fri Feb 22 19:48:26 2008] [notice] Child 2732: Child process is running
[Fri Feb 22 19:48:26 2008] [notice] Child 2732: Acquired the start mutex.
[Fri Feb 22 19:48:26 2008] [notice] Child 2732: Starting 250 worker threads.
[Fri Feb 22 19:48:26 2008] [notice] Child 2732: Starting thread to listen on port 443.
[Fri Feb 22 19:48:26 2008] [notice] Child 2732: Starting thread to listen on port 80.
datablock position = 2048
datablock position = 2048
datablock position = 2048

Is is possible that PHP is not turned on? PHP is not listed in the XAMPP control panel. Now can I check this?
rmpowell01
 
Posts: 3
Joined: 23. February 2008 08:28

Postby Wiedmann » 23. February 2008 18:56

What's about my first question?
Wiedmann wrote:The demopage ("http://localhost/xampp/") is not working?


Code: Select all
datablock position = 2048
datablock position = 2048
datablock position = 2048

Sorry, never seen this in the "error.log". The rest looks fine.

Is is possible that PHP is not turned on?

Not in a default fresh XAMPP installation without any changes. Mybe there are something left from your individual PHP installation? (an other "php.ini", environment variables, registry settings?)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

PHP is active but not processing

Postby rmpowell01 » 23. February 2008 18:57

PHP is active, or so the XAMPP Status in http://localhost/ say it is.

Can someone tell me why when I open index.php "c:\xampp\htdocs\index.php" PHP does not process?
rmpowell01
 
Posts: 3
Joined: 23. February 2008 08:28

Postby Wiedmann » 23. February 2008 19:11

Can someone tell me why when I open index.php "c:\xampp\htdocs\index.php" PHP does not process?

How did you open this file exactly?

(For this file, you must use "http://localhost/index.php".)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests