Perl addon Perl 5.8.8-2.2.8

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Perl addon Perl 5.8.8-2.2.8

Postby you2wire » 12. February 2008 15:40

I just upgraded my XAMPP to the lastest version 1.6.6 so i could use the perladdon. I downloaded the new perl addon Perl 5.8.8-2.2.8 and everything fine. the only problem is that my apache will be start. i am getting an error as follows.

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
apache.exe: Syntax error on line 523 of C:/xampp/apache/conf/httpd.conf: Could not open configuration file C:/xampp/apache/conf/extra/perl.conf: The system cannot find the file specified.

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .

I added in the Httpd.conf file AddHandler cgi-script .cgi .pl

My question what else do i need to do with the httpd.conf or the perl.conf to make it work.

I am running Http.VHost
Please i need your help my sites is DOWN
Posts: 1
Joined: 12. February 2008 15:21

Postby Izzy » 13. February 2008 00:29

It sounds like you did not run the setup-xampp.bat file after installing the addon.

Apache needs the file it can't find or it will not start.

Try installing the addon again and follow the instructions in the readme-addon-perl.txt to the letter.

BTW the bat file needs to be run twice according to the instructions in the readme file.

Note - PM by invitation only!
Posts: 3344
Joined: 25. April 2006 17:06

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 76 guests