Pls somebody help me with apache!!!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Pls somebody help me with apache!!!

Postby maceee » 08. February 2008 21:43

Hello , I am dreally desperate since i can't set up my server and don't really know what's wrong.

I use zoneedit got dynamic dns which is correctly updated, and my apachge listen to port 80.

my apache vhosts file is :

NameVirtualHost *:80

<VirtualHost *:80>
ServerAdmin info@adultsmatches.com
DocumentRoot c:/wamp/www
ServerName adultsmatches.com
ServerAlias www.adultsmatches.com
ErrorLog c:/wamp/logs/error.log
CustomLog c:/wamp/logs/access.log common
</VirtualHost>


my hosts file look like :
127.0.0.1 localhost
127.0.0.1 adultsmatches.com

and have forward 80 port to my ip.

MY isp surely doesn't block incoming 80 traffic.

Apache seems to go correctly online but when i try to access my site from outside my network it redirects to localhost instead of www.adultsmatches.com


Can pls someone tell me if something is wrong?

many thanks in advance[/b]
maceee
 
Posts: 5
Joined: 08. February 2008 21:36

Postby Scory » 08. February 2008 22:35

>127.0.0.1 adultsmatches.com

Of course, this is wrong. You have to apply your internal LAN IP instead, for example:

192.168.1.10 adultsmatches.com

It must be the same IP as mentioned in the Routers Port Forwarding.
Scory
 

Postby maceee » 08. February 2008 22:47

i changed it 10.0.0.2 as is my internal ip and when i forward port 80 from my router it still tries to open localhost instead of adultsmaches.com and when i do not forward port 80 althought it target adultsmatches.com page oen't open.

can you pls help me?

thank you
maceee
 
Posts: 5
Joined: 08. February 2008 21:36

Postby Scory » 08. February 2008 23:43

Show us the FULL VirtualHost Configuration (your example above is incomplete and wrong!).
Scory
 

Postby maceee » 08. February 2008 23:51

i don't have anything ele to vhosts file expect from the comments.

thank you very much
maceee
 
Posts: 5
Joined: 08. February 2008 21:36

Postby Wiedmann » 09. February 2008 00:28

but when i try to access my site from outside my network it redirects to localhost
...
Can pls someone tell me if something is wrong?

This redirect is made from your PHP script. Read the script documentation or ask the author of the script, how to configure this script correctly.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby maceee » 09. February 2008 01:28

no..no..it has not to do with the script..it is clearly an apache issue and i knwo tht cause i used to make it work with the same script but this time i do something wrong...
maceee
 
Posts: 5
Joined: 08. February 2008 21:36

Postby Wiedmann » 09. February 2008 01:50

it is clearly an apache issue

Why did you think it's an Apache issue?

it has not to do with the script

Why not?
--> The redirect header is definitely set by a PHP script.

BTW:
This is the forum for the XAMPP server package, not for the WampServer package.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby maceee » 09. February 2008 09:35

it is surely apache issue cause i had once configuresd it to play online with the same script without to do anything to the script..

so i am sute it is an apache issue
maceee
 
Posts: 5
Joined: 08. February 2008 21:36

Postby Izzy » 09. February 2008 10:09

maceee wrote:it is surely apache issue cause i had once configuresd it to play online with the same script without to do anything to the script..

so i am sute it is an apache issue

As pointed out above. your Apache/PHP problems can't be answered on this XAMPP forum, absolutely not possible.

You need to ask your questions at the forum linked below where you will be sure of getting help:
http://wampserver.com/phorum
They have French and English help forums - good luck with it.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Scory » 09. February 2008 14:34

maceee wrote:i don't have anything ele to vhosts file expect from the comments.


The few lines above is your full vhost-conf-file? Where is the declaration of localhost (for example)? You must supply at least two different vhosts (I can see only one!).

As localhost and adultsmatches.com are based on different IPs, you have to configure IP-based Vhosts, but youre (incomplete) configuration is NOT IP-Base but Name-based (what causes the problems).

In contradiction to the other members I am pretty sure that the faulty configuration of the vhosts are causing youre problems.
Scory
 


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests