problem with addon

Problems with the Windows version of XAMPP, questions, comments, and anything related.

problem with addon

Postby Dark_hunter » 03. February 2008 11:42

i already install xampp for windows , but i can't install addon , it's appear error : Apache Version 2.2.4 not found , need XAMPP 1.6 .
I'm using XAMPP 1.65 , it's does not support mod_perl , how can i install pert with this version ????
Posts: 1
Joined: 03. February 2008 11:29

Re: problem with addon

Postby Izzy » 03. February 2008 12:17

Dark_hunter's appear error : Apache Version 2.2.4 not found...
You really should take the time to read what the developers have gone to the trouble of writing for you, of what you need to do to install the proper versions.

This quote from the page you downloaded the plug-in from which quite clearly states the versions that it supports - Apache 2.2.4 - but in XAMPP 1.6.5 the Apache version is 2.2.6 so it is obvious that you will get an error, don't you think.
Perl 5.8.8-2.2.4
XAMPP 1.6.x
Apache 2.2.4 Mod_Perl does not function with Apache 2.2.6 (XAMPP 1.6.4)!
Perl 5.8.8 and mod_perl 2.0.3 Add-on package for the current XAMPP 1.6.x with Apache 2.2.4. Needs NT, 2000 or XP systems! For the older XAMPP Version you need the older Perl XAMPP add-ons on See also README + PPM Modules inside

And if you had also taken the trouble to read the linked README file, which is put there so you can read it, you would have seen this right at the top of the README page:
Add-on Perl 5.8.8 Apache 2.2.4
Only for XAMPP with Apache 2.2.4

So if you want to run this Active Perl Plug-in you have 2 choices:
1. Install the version of XAMPP that includes Apache 2.2.4 - XAMPP 1.6.3a was the last release that had Apache 2.2.4 included.
(Older versions of XAMPP can be found by clicking on the Source Forge link found at the top of the same page you downloaded the wrong plug-in from that you also failed to read).

2. Wait for the soon to be released new version of XAMPP 1.6.6, currently in late Beta, and which will usually have available a compatible updated version of the Active Perl Plug-in - the Apache version 2.2.8 included in XAMPP 1.6.6 also includes the mod_perl bug fix.
Posts: 3344
Joined: 25. April 2006 17:06

Postby keeboudi » 23. April 2008 12:12

Hi Izzy
Unless I am being particularly dense, I can't see which older perl add-on will work with which older XAMPP ... on this page: ... _id=113693
Any ideas?
Posts: 1
Joined: 23. April 2008 11:49

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 34 guests