Problem Using XAMPP & Full version release of osCMax 2.0

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem Using XAMPP & Full version release of osCMax 2.0

Postby gumshoesrus » 24. January 2008 15:53

NOVICE WEBMASTER IN NEED OF SOME HELP.

:( I'm having trouble with my osCMax Shopping cart.
I cannot get the SEO URLs to work properly with XAMPP.

:arrow: I'm using WinXP Pro with all updates.
I'm using XAMPP (basic package) version 1.6.4
My shopping cart is Full version release of "osCMax 2.0 RC3"
downloaded from
http://oscdox.com/Downloads-req-viewdownload-cid-6.html

:!: I'm sure that some settings are not done correctly.
An answer would be greatly appreciated.
As many users have this exact same problem.

Here is a copy of an email sent to osCMax tech support
:x (They didn't respond, yet.)

Dear Tech Support,

I recently downloaded and installed the Full version release of osCMax 2.0 RC3 in .zip format.

I'm having trouble getting the SEO Urls to work properly.
Everything else seems to be working properly,
I haven't noticed any other issues.

When I have these settings, you can't visit any products on my page,
When set, I can see the new URLs in the category listings when you rollover onto the category links, but when I click on them,
I get an error stating that these pages are outdated.
Page 404 error.

SEO URLs Settings from the Admin Section (That don't work.)

Title Value
Enable SEO URLs? true
Choose URL Type Rewrite
Filter Short Words 3
Reset SEO URLs Cache false

When I reset "enable SEO URLs?" back to "false".
Everything works fine again.

I'm running my Computer on WinXP Pro with all updates.
And I'm using XAMPP as my Server with PHP 4.4.7 running.
PHP 5 doesn't work well with some other programs.
So, I'd like to keep PHP 4.4.7 running on this machine.

:?: Am I missing something? or Do I have something set wrong in my PHP?
I don't know I'm new at this webmastering thing.
This is the first time I've actually running a site from my home.

Can you help me? Because I think this is why my site isn't being indexed properly.
I see none of my products in the Category listing showing up in the search engines.

:wink: I appreciate your time, any suggestions will be appreciated.

Thanks Sincerely
Mike Montgomery

:wink: Any suggestions please contact me at:
montgomeryinc575@bellsouth.net
Last edited by gumshoesrus on 25. January 2008 14:30, edited 3 times in total.
gumshoesrus
 
Posts: 3
Joined: 24. January 2008 15:19

Postby Izzy » 25. January 2008 02:23

Thanks for editing your post but please read the PM (Personal Message) I sent and take action to complete the process.
Last edited by Izzy on 26. January 2008 23:04, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

I tried that.

Postby gumshoesrus » 25. January 2008 03:19

I did try that already.
It didn't make any difference.
I've left that line uncommented in my httpconf file,
I did restart Apache, and nothing changed.
The only thing I didn't try was restarting my computer,
and see if this is a reboot issue?
It probably won't make any difference.
But, for peace of mind I'll try it.

Any other suggestions?

I find it strange that there are others out there with this problem.
And I've search high and low on the internet for a solution.

:arrow: Hopefully, when I can find a solution, I'm not going to delete this
Forum and hope that other Search Engines will catch this solution
so others can benefit from this specific problem.

Another problem that I have and it's not related to my shopping cart.

When I updated my XAMPP to it's present version.
My PHP Admin (after login) states that My PHP Library version is different than MySQL version and that my programs may act strange.

:shock: How do I correct this issue without reinstalling and loosing a whole years worth of work, on 12 different sites that I'm hosting?

I do appreciate the help.
I'm going to be helping other Family members with this shopping cart,
and I'm going to be hosting about 12 of their shopping carts on my server.

Thanks again for all of your help and suggestions.

Sincerely
Mike Montgomery
gumshoesrus
 
Posts: 3
Joined: 24. January 2008 15:19

Other Changes That Were Done...

Postby gumshoesrus » 25. January 2008 14:14

I also made the following changes to my (Main) php.ini file

In bold letters below I added:

; The URL rewriter will look for URLs in a defined set of HTML tags.
; form/fieldset are special; if you include them here, the rewriter will
; add a hidden <input> field with the info which is otherwise appended
; to URLs. If you want XHTML conformity, remove the form entry.
; Note that all valid entries require a "=", even if no value follows.
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset=,index.php?cName=,index.php?pName="

And I restarted the whole computer...
No Change on this issue.

Other changes that I've tried...

From my Shopping Cart Admin Section,

In the "SEO URLs"
When I change this to:

Title Value Action
Enable SEO URLs? set to "false"
Choose URL Type set to "cName"
Filter Short Words set to "0"
Reset SEO URLs Cache set to "false"

The links look like this:
http://www.mysitesname.com/catalog/index.php?cPath=20

When I change this to:

In the "SEO URLs"

Title Value Action
Enable SEO URLs? set to "true"
Choose URL Type set to "cName"
Filter Short Words set to "0"
Reset SEO URLs Cache set to "false"

The links look like this:
http://www.mysitesname.com/catalog/inde ... =batteries

Now from both of these settings listed above, I can get to all of my products.

But, when I change to this:

In the "SEO URLs"

Title Value Action
Enable SEO URLs? set to "true"
Choose URL Type set to "Rewrite"
Filter Short Words set to "0"
Reset SEO URLs Cache set to "false"

The links look like this:
http://www.mysitesname.com/catalog/batteries-c-20.html
This link is my main goal for Search Engine Optimization.

But this is where I run into trouble.
Although on the main page of my site,
When I scroll over the "category" links I can see the link:
http://www.mysitesname.com/catalog/batteries-c-20.html

When I click on these links, this is when I get the following error:

Object not found!
The requested URL was not found on this server.
The link on the referring page seems to be wrong or outdated.
Please inform the author of that page about the error.

If you think this is a server error, please contact the webmaster.

Error 404
www.mysitesname.com
01/25/08 07:46:20
Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/0.9.8e mod_autoindex_color PHP/4.4.7

I've reset the values back to:

In the "SEO URLs"

Title Value Action
Enable SEO URLs? set to "true"
Choose URL Type set to "cName"
Filter Short Words set to "0"
Reset SEO URLs Cache set to "false"

The links look like this:
http://www.mysitesname.com/catalog/inde ... =batteries

But I've been told time and again that with the question mark (?) in the link.
That search engines may not or even quit indexing my site.
So all of my products may not get indexed into the search engines.
And on just this one site alone, I'm planning on adding 18,000 products.
And it would be nice to have the search engines index 18,000 products...
This is what I am to understand about SEO's.
That this is the type of links that search engines like.
http://www.mysitesname.com/catalog/batteries-c-20.html

Since I'm new to webmastering, Am I wrong in this assumption?

Also, I've Reset SEO URLs Cache everytime I've made any changes in this section.
And still no change in URL performance.

If you need I can send you a copy of my httpd.conf and php.ini file for you to review.

Thanks again for your assistance.
Mike
gumshoesrus
 
Posts: 3
Joined: 24. January 2008 15:19

Postby Izzy » 31. January 2008 04:25

Thanks again for your edits - it may seem a trivial issue but being a family man yourself, I feel sure you understand.


I also made the following changes to my (Main) php.ini file
Where is this (Main) php.ini file located?

Use http://localhost/xampp/phpinfo.php to determine which php.ini file is being used and make edits in this file only.

Because your using an old php version and maybe the script you are using also has not been php code updated, try experimenting with the register_globals settings in the php.ini file:

If
register_globals = Off
change to
register_globals = On
and vice versa to see if there is any change in your issue.

Restart the server after editing the php.ini file but always make a backup of any ini or conf file before editing so you can revert if there are any editing issues, and of course, best practice is to always have a copy of the default configuration files before any edits were made at all, so you have 'a fresh start from the beginning' point to fall back on.

register_globals = Off is recommended for most newer versions and code authors should try and write their scripts for register_globals = Off

There is a bug in php 4.4.7 regarding url rewriter:
http://bugs.php.net/bug.php?id=41600
Fixed in later versions which may also fix most of your other issues.

http://us3.php.net/session
php manual wrote: url_rewriter.tags
url_rewriter.tags specifies which HTML tags are rewritten to include session id if transparent sid support is enabled. Defaults to a=href,area=href,frame=src,input=src,form=fakeentry,fieldset=


url rewriter in php.ini is Session related, so are you sure that this is relevant in your situation - the use of the .htaccess and mod_rewrite properly configured and working should be all that is required and is much like the Permalink feature in Wordpress which only uses this method as do many other similar scripts and cart scripts.


IMHO, just concentrating on fixing this one .htaccess method instead of poking around in multiple methods would be the way to go, as you may be only compounding the issues you have.
Starting with a fresh php.ini file (that is minus the other related edits you made) may be the way to go, so at least we know that the php.ini file is not interfering with our .htaccess attempts.

You may also like to check out the Apache error.log file at the time you try a url rewrite for any clues - usually a very good source for clues when anything is not quite right with the server.
.\xampp\apache\logs\error.log
If this file is very big then you can delete most of the entries using a text editor when your server is stopped.

Web browser error messages are hard coded and don't tell you anything of value, only the error code like 404 page not found is helpful, but go to the server's error.log and it will tell you all about that 404 error in detail.


In your .htaccess make sure the RewriteBase is set for your catalog directory and not the root directory RewriteBase /

Example - for this address:
http://www.mysitesname.com/catalog/

it would look like this:

RewriteEngine on
RewriteBase /catalog



Are you using <VirtualHost> containers for your various domains?

Are you using the .\xampp\apache\conf\extras\httpd-vhosts.conf file instead of cluttering up your httpd.conf file?

In your <Directory> directives to have .htaccess files parsed you need to have at least these 2 lines included:
<Directory /path>
AllowOverride All
Options +FollowSymlinks
</Directory>

There is only a need to restart the Apache server after configuration changes to have them recognized not a system reboot.

BTW, Anything that is related to your script should be directed at the script's author and in your particular case, the contributing author of the SEO url contribution.
(This may be hard to do as I believe he has been banned from the forum, but there is possibly a contact link somewhere in an old post perhaps).
Also this issue of yours has been discussed multiple times on their forums some posts having a huge number of pages to search through - good practice for a PI. :wink:

Any issue that is XAMPP related and in particular server configuration issues may well be answered here by any one of the many knowledgeable members who pop in from time to time - the support on these forums is by those generous members who give up some of their precious spare time to help other members who have issues that may need a solution.



If you want to know all about what Google do and have some control over your SEO, go to the Google web site and register for a free Google Account - then Sign in, then click on My Account, then click on Webmaster Tools - it is very helpful in getting a handle on what Google expects of you, so no more hear say get it from the horses mouth.
Google's webmaster tools provide you with a free and easy way to make your site more Google-friendly. Using our tools, you can:

Get Google's view of your website, and diagnose potential problems.
See how Google crawls and indexes your site and learn about specific problems we're having accessing it.

See how your site is performing.
Learn which queries drive traffic to your site, and see exactly how users arrive there.




STRONG TIP - if you don't want your email inbox filled with other peoples spam then I suggest you remove your email address from your posts - this is yummy spam bot food.



I'm running my Computer on WinXP Pro with all updates.
And I'm using XAMPP as my Server with PHP 4.4.7 running.
PHP 5 doesn't work well with some other programs.
So, I'd like to keep PHP 4.4.7 running on this machine.

Does this mean that you are running 2 instances of PHP on the same PC? - a separate php 4.4.7 and the php included in XAMPP.

How have you got this configured?

Your error:
My PHP Admin (after login) states that My PHP Library version is different than MySQL version and that my programs may act strange.
seems to indicate that one or the other may be in conflict or confused which may well be related to multiple php instances, and not to mention that it may be affecting the other issues you have.

If you are running multiple php instance then there is no need as you can run php4 in XAMPP by switching from php5 to php4 and back again using the .\xampp\php-switch.bat file, then Apache, MySQL and phpMyAdmin will be configured correctly so they all run in unison and harmony.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 35 guests