localhost do not work

Problems with the Windows version of XAMPP, questions, comments, and anything related.

localhost do not work

Postby hugohugo » 23. January 2008 10:05

hey hey

My localhost do not work :(
i triet to run xampp-portcheck but if i open xampp-portcheck than close Windows vitsa it. :(

My log:
C:\xampp\apache\logs

[Tue Jan 22 23:00:58 2008] [notice] Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5 configured -- resuming normal operations
[Tue Jan 22 23:00:58 2008] [notice] Server built: Nov 7 2007 11:48:48
[Tue Jan 22 23:00:58 2008] [notice] Parent: Created child process 2484
[Tue Jan 22 23:01:00 2008] [notice] Child 2484: Child process is running
[Tue Jan 22 23:01:00 2008] [notice] Child 2484: Acquired the start mutex.
[Tue Jan 22 23:01:00 2008] [notice] Child 2484: Starting 250 worker threads.
[Tue Jan 22 23:01:00 2008] [notice] Child 2484: Starting thread to listen on port 80.
[Tue Jan 22 23:01:00 2008] [notice] Child 2484: Starting thread to listen on port 443.
[Tue Jan 22 23:02:08 2008] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Tue Jan 22 23:02:09 2008] [notice] Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5 configured -- resuming normal operations
[Tue Jan 22 23:02:09 2008] [notice] Server built: Nov 7 2007 11:48:48
[Tue Jan 22 23:02:09 2008] [notice] Parent: Created child process 5348
[Tue Jan 22 23:02:10 2008] [notice] Child 5348: Child process is running
[Tue Jan 22 23:02:10 2008] [notice] Child 5348: Acquired the start mutex.
[Tue Jan 22 23:02:10 2008] [notice] Child 5348: Starting 250 worker threads.
[Tue Jan 22 23:02:10 2008] [notice] Child 5348: Starting thread to listen on port 443.
[Tue Jan 22 23:02:10 2008] [notice] Child 5348: Starting thread to listen on port 80.
[Wed Jan 23 06:59:08 2008] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Wed Jan 23 06:59:11 2008] [notice] Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5 configured -- resuming normal operations
[Wed Jan 23 06:59:11 2008] [notice] Server built: Nov 7 2007 11:48:48
[Wed Jan 23 06:59:11 2008] [notice] Parent: Created child process 2356
[Wed Jan 23 06:59:13 2008] [notice] Child 2356: Child process is running
[Wed Jan 23 06:59:13 2008] [notice] Child 2356: Acquired the start mutex.
[Wed Jan 23 06:59:13 2008] [notice] Child 2356: Starting 250 worker threads.
[Wed Jan 23 06:59:13 2008] [notice] Child 2356: Starting thread to listen on port 443.
[Wed Jan 23 06:59:13 2008] [notice] Child 2356: Starting thread to listen on port 80.


thnx gr hugo
hugohugo
 
Posts: 1
Joined: 23. January 2008 09:18

Can't connect to localhost using xampp-win32-1.6.5-installer

Postby almenzies » 05. February 2008 08:35

Hi, I'm having the same problem.

I'm using Vista business with xampp-win32-1.6.5-installer.

The XAMPP control panel shows both Apache and mySQL services as running fine - however trying to connect to http://localhost/ times out every time.

In addition I can't connect to the Apace admin (as it's at localhost), but if I try to connect to mySQL admin I get an error saying "access violation at address 10002593 in module 'LIBMYSQL.dll'. Read of address 00000000"

My logs spit out the following:

[Tue Feb 05 09:39:35 2008] [notice] Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5 configured -- resuming normal operations
[Tue Feb 05 09:39:35 2008] [notice] Server built: Nov 7 2007 11:48:48
[Tue Feb 05 09:39:35 2008] [notice] Parent: Created child process 5896
[Tue Feb 05 09:39:37 2008] [notice] Child 5896: Child process is running
[Tue Feb 05 09:39:37 2008] [notice] Child 5896: Acquired the start mutex.
[Tue Feb 05 09:39:37 2008] [notice] Child 5896: Starting 250 worker threads.
[Tue Feb 05 09:39:37 2008] [notice] Child 5896: Starting thread to listen on port 443.
[Tue Feb 05 09:39:37 2008] [notice] Child 5896: Starting thread to listen on port 80.

As with the other user I also can't use xampp-portcheck.exe - it just crashes every time.

Anyone have any ideas, this is really frustrating.

Many thanks.,
Al.
almenzies
 
Posts: 3
Joined: 05. February 2008 08:22

Postby Scory » 05. February 2008 12:02

> however trying to connect to http://localhost/ times out every time.

Did you try http://127.0.0.1 instead? If it works, your hosts-File is missing an entry for the "localhost" loopback device (127.0.0.1).

I dont know Vista, but under XP you will find the hosts-File in C:\Windows\system32\drivers\etc and it's simply called "hosts" (without extension).
Scory
 

Postby almenzies » 05. February 2008 22:54

Hey Scory,

Thanks for your response - yeah http://127.0.0.1 does work (once I disable Skype!).

However my hosts file (located in the same place as XP) looks fine. Here is the content pasted exactly as it appears in the file, localhost is referenced at the bottom:

# Copyright (c) 1993-2006 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

127.0.0.1 localhost
::1 localhost
almenzies
 
Posts: 3
Joined: 05. February 2008 08:22

Postby Izzy » 05. February 2008 23:50

Delete this line and see if it helps:
::1 localhost
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby almenzies » 06. February 2008 00:19

Thanks Izzy, nice one - that worked.

I also had to kick Skype off port 80.

For anyone else that needs to do this just open skype and navigate to:

Tools > options > advanced > connections

then uncheck the box that says 'use port 80 and 443 as alternatives for incoming connections'

Restart skype and there should be no conflict with XAMPP.
almenzies
 
Posts: 3
Joined: 05. February 2008 08:22

Postby scottysbody » 12. February 2008 21:39

I'm having this same problem. I can't connect through http://localhost or through http://127.0.0.1. I don't have skype installed on this computer and my host file looks fine.

Any suggestions?
scottysbody
 
Posts: 1
Joined: 12. February 2008 21:25

Postby LooseCannon » 15. February 2008 18:19

Hello and welcome scottysbody.

What do you mean 'can't connect'? Your browser times out, takes you to the wrong page, provides an error or something? Have you checked your log files, which you'll note both the thread starter and second poster did and posted information therefrom.

Please provide some meat for us to chew on.
User avatar
LooseCannon
 
Posts: 162
Joined: 18. September 2007 12:07
Location: Hampshire, UK

Postby irox » 02. March 2008 15:11

I'm having this same problem, help...

(Excuse my bad English I'm Italian)...

I have a xampp 2 years and has always worked. But then week has not started to connect more to the localhost / 127.0.0.1 , not showing anything (blank page and not stop more loading) ...


I uninstalled the old xampp , and I have installed the new 1.6.6a installer (I also clean the registry), but has not changed anything ... not load anything, Blank page end no massage error.

This is my Apache/log/error

Code: Select all
[Sun Mar 02 13:02:32 2008] [notice] Apache/2.2.8 (Win32) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5 configured -- resuming normal operations
[Sun Mar 02 13:02:32 2008] [notice] Server built: Jan 18 2008 00:37:19
[Sun Mar 02 13:02:32 2008] [notice] Parent: Created child process 3172
[Sun Mar 02 13:02:34 2008] [notice] Child 3172: Child process is running
[Sun Mar 02 13:02:34 2008] [notice] Child 3172: Acquired the start mutex.
[Sun Mar 02 13:02:34 2008] [notice] Child 3172: Starting 250 worker threads.
[Sun Mar 02 13:02:34 2008] [notice] Child 3172: Starting thread to listen on port 443.
[Sun Mar 02 13:02:34 2008] [notice] Child 3172: Starting thread to listen on port 80.
[Sun Mar 02 13:04:44 2008] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Sun Mar 02 13:04:44 2008] [notice] Child 3172: Exit event signaled. Child process is ending.
[Sun Mar 02 13:04:45 2008] [notice] Child 3172: Released the start mutex
[Sun Mar 02 13:05:14 2008] [notice] Parent: Forcing termination of child process 440
[Sun Mar 02 13:05:32 2008] [notice] Apache/2.2.8 (Win32) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5 configured -- resuming normal operations
[Sun Mar 02 13:05:32 2008] [notice] Server built: Jan 18 2008 00:37:19
[Sun Mar 02 13:05:32 2008] [notice] Parent: Created child process 1612
[Sun Mar 02 13:05:34 2008] [notice] Child 1612: Child process is running
[Sun Mar 02 13:05:34 2008] [notice] Child 1612: Acquired the start mutex.
[Sun Mar 02 13:05:34 2008] [notice] Child 1612: Starting 250 worker threads.
[Sun Mar 02 13:05:34 2008] [notice] Child 1612: Starting thread to listen on port 443.
[Sun Mar 02 13:05:34 2008] [notice] Child 1612: Starting thread to listen on port 80.
[Sun Mar 02 14:18:10 2008] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Mar 02 14:19:10 2008] [notice] Apache/2.2.8 (Win32) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5 configured -- resuming normal operations
[Sun Mar 02 14:19:10 2008] [notice] Server built: Jan 18 2008 00:37:19
[Sun Mar 02 14:19:10 2008] [notice] Parent: Created child process 2368
[Sun Mar 02 14:19:18 2008] [notice] Child 2368: Child process is running
[Sun Mar 02 14:19:18 2008] [notice] Child 2368: Acquired the start mutex.
[Sun Mar 02 14:19:18 2008] [notice] Child 2368: Starting 250 worker threads.
[Sun Mar 02 14:19:18 2008] [notice] Child 2368: Starting thread to listen on port 443.
[Sun Mar 02 14:19:18 2008] [notice] Child 2368: Starting thread to listen on port 80.


My portcheck is ok: is all free

How can I fix my problem?

I have windows XP, i don't have skype installed on this computer and my host file looks ok.
irox
 
Posts: 2
Joined: 02. March 2008 14:44

Postby irox » 04. March 2008 10:24

Hello everyone,

Who has this problem can try to fix it writing Https://127.0.0.1

Instead of Http://127.0.0.1

It worked for me, although it is not the right solution ....

Good job
irox
 
Posts: 2
Joined: 02. March 2008 14:44


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 70 guests