Problem logging in to /xampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem logging in to /xampp

Postby RandomZero » 14. January 2008 18:28

I'm pretty sure I haven't changed anything, but when I go to /xampp on my webserver it asks for a username/password. Any username/pass I try just leads to
Code: Select all
Server error!
The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

If you think this is a server error, please contact the webmaster.

Error 500
192.168.0.110
01/14/08 12:24:26
Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5


Did I delete something I wasn't supposed to?
RandomZero
 
Posts: 5
Joined: 14. January 2008 18:17

Postby Izzy » 15. January 2008 00:49

When receiving a server error always check the Apache error.log file for more informative clues:
.\xampp\apache\logs\error.log
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby RandomZero » 15. January 2008 13:20

Code: Select all
(OS 2)The system cannot find the file specified.  : Could not open password file: C:/Program Files/XAMPP/security/xampp.users

But that file doesn't exist, and it isn't in the .zip.. So why would it be looking for a file that has never existed?

What would I be putting in this file to make it work?
RandomZero
 
Posts: 5
Joined: 14. January 2008 18:17

Postby Wiedmann » 15. January 2008 13:27

But that file doesn't exist, and it isn't in the .zip.. So why would it be looking for a file that has never existed?

Delete the ".htaccess" files in:
"C:\Program Files\XAMPP\htdocs\xampp"
"C:\Program Files\XAMPP\security\htdocs"
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby RandomZero » 15. January 2008 13:37

Eh, I got it working.

Just changed it to my .htpasswd file instead... Which leads to another question..


When I try and encrypt the password (Using one of the many websites that will do it..) it never works.. How would I fix that?
RandomZero
 
Posts: 5
Joined: 14. January 2008 18:17

Postby Wiedmann » 15. January 2008 13:48

When I try and encrypt the password (Using one of the many websites that will do it..) it never works.. How would I fix that?

Use the tool "htpasswd.exe":
http://httpd.apache.org/docs/2.2/howto/ ... gitworking
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby RandomZero » 16. January 2008 20:39

Awesome! Thanks :)
RandomZero
 
Posts: 5
Joined: 14. January 2008 18:17


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests