Please Help Virtual Host dont know whats wrong

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Please Help Virtual Host dont know whats wrong

Postby Wim77 » 13. January 2008 17:05

Can someone please help me

im running apachefriends on windows server 2003

and i want to set up a virtualhost

i did this but nothing works

<VirtualHost *:80>
ServerName localhost
DocumentRoot "C:/xampp/htdocs"
<Directory "C:/xampp/htdocs">
Options Indexes FollowSymLinks Includes ExecCGI
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName www.autohitter.tk
#ServerAlias http://www.autohitter.tk/
DocumentRoot "C:/xampp/htdocs/kliks"
<Directory "C:/xampp/htdocs/kliks">
Options Indexes FollowSymLinks Includes ExecCGI
#AllowOverride All
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName dutchautohitter.tk
ServerAlias www.dutchautohitter.tk
ServerAdmin serveradmin@dutchautohitter.tk
DocumentRoot "C:/xampp/htdocs/kliks"
<Directory "C:/xampp/htdocs/kliks" >
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>
CustomLog logs/dutchautohitter.tk.access.log combined
ErrorLog logs/dutchautohitter.tk.error.log
</VirtualHost>

i have tried it with ipnumbers but i cant find what i did wrong

i have read alot of topics and i cant find the problem

please help me

thanks
Wim77
 
Posts: 1
Joined: 13. January 2008 17:00

Postby RSXHiTMAN » 15. January 2008 12:03

.tk isnt a top level domain and has no dns support
RSXHiTMAN
 
Posts: 4
Joined: 28. January 2007 01:11

Postby Izzy » 15. January 2008 12:44

RSXHiTMAN wrote:.tk isnt a top level domain and has no dns support


Ooops!
Dot tk is the Internet country code top-level domain (TLD) for Tokelau, a territory of New Zealand located in the South Pacific.

http://www.dot.tk/en/index.html?lang=en

http://www.iana.org/root-whois/tk.htm

Take a note of the IANA link below then you can refer to it when needed - just so you can be more informative in future. ;)
http://www.iana.org/root-whois/index.html
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Izzy » 15. January 2008 13:19

Try this as you are close - I have highlighted the changes and what needs changing at your end.

Also make sure the ports are open in your router, your Firewall is not blocking access and you have configured your DNS to point to your IP.
NameVirtualHost *.80

<VirtualHost *:80>
ServerName localhost
DocumentRoot "C:/xampp/htdocs"
<Directory "C:/xampp/htdocs">
Options Indexes FollowSymLinks Includes ExecCGI
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName autohitter.tk
ServerAlias www.autohitter.tk/
DocumentRoot "C:/xampp/htdocs/kliks"
<Directory "C:/xampp/htdocs/kliks">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName dutchautohitter.tk
ServerAlias www.dutchautohitter.tk
ServerAdmin serveradmin@dutchautohitter.tk
DocumentRoot "C:/xampp/htdocs/kliks"
<Directory "C:/xampp/htdocs/kliks">

Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>
CustomLog logs/dutchautohitter.tk.access.log combined
ErrorLog logs/dutchautohitter.tk.error.log
</VirtualHost>

If you still get errors try to change this directory to a different location to the first vhost:
DocumentRoot "C:/xampp/htdocs/kliks"
<Directory "C:/xampp/htdocs/kliks">


Example:
DocumentRoot "C:/xampp/htdocs/kliksdutch"
<Directory "C:/xampp/htdocs/kliksdutch">

To check for errors and syntax open a command console window in:
C:\xampp\apache\bin
Type apache -S at the command prompt.

Paste the result here - to copy and paste click on the little icon top left in the title bar of the command console window and select Edit from the context menu.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 59 guests