Missing parameter: goto

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Missing parameter: goto

Postby bannisa2 » 09. January 2008 22:44

I have have downloaded and attempted to install XAMPP-win32-1.6.5-installer.exe

All appears OK until I try and use phpmyAdmin to create tables.

I can create a new database, but if I try to import a .sql file I get two error messages of the form "Missing parameter: goto (FAQ 2.8 ) ".

If I try to use the SQL option to create a table, I find there is no text area shown where I can type the code.

I also find that if I try and add a new user using the link on the users page the screen refreshes but nothing else happens.

If I try and save a new record to the users table in the mysql database I get a Missing parameter: goto (FAQ 2.8 ) error message.

FAQ 2.8 lists a number of possible problems, but none appear to apply. (As I have installed all the config files as supplied this is not surprising.)

I have searched the web for ideas and although I find a number of forum queries of a similar nature, I have never seen a solution!

One possible area of investigation is that I have a version of phpdev installed on the machine. I have done all I can to ensure there is no conflict, but I guess I might have overlooked something.

Anyone have any suggestions, or will this be yet another forum with an unaswered question on this topic!
bannisa2
 
Posts: 7
Joined: 09. January 2008 22:17
Location: Abbots Langley, UK

Postby Izzy » 10. January 2008 00:17

What browser are you using and what OS?

There has been issues with browser type and a recommendation for a fix was to try the Firefox browser if not using already.

Have you made any changes in any of the phpMyAdmin, MySQL or PHP configuration files?

If so, can you let us know the details of what they were?

I did a bit of a tutorial on creating a database etc. for another member using Wordpress as an example.

See if this helps after trying to follow it:
http://community.apachefriends.org/f/viewtopi ... 258#112258

Also make sure you don't have any other MySQL instances on your system running as a service perhaps - check the Task Manager or the Service Manager for this.

Also won't hurt to run xampp\xampp-portcheck.exe before starting any of the XAMPP modules - all ports should be Free.

BTW it is not advisable to edit any of the existing databases you find in phpMyAdmin as you may course untold damage for XAMPP and may ultimately require you to re install XAMPP to fix it - even the database named test.

Create a new database of your own for experimenting with.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby bannisa2 » 10. January 2008 01:11

Hi, and thanks for caring for a poor sad old Pom!

I'm running Win XP Pro SP2. I have tried Firefox 2, IE7, Opera 9 - all behave the same way. Have also installed XAMPP 1.6.5, 1.6.4 and 1.6.3 in hope that a change of phpmyAdmin fixed the problem. I am now simply testing by trying to add a record to the user table in mysql database. This generates the error:

tbl_replace.php: Missing parameter: goto (FAQ 2.8 ). I guess there is a common thread here.

Have checked the ports as suggested. With Apache and mySQL stopped all ports are shown as free. With it running ports 80, & 443 are allocated to Apache and 3306 to mySQL.

Finally, all instances of Apache and mySQL disappear from the Task Manager when the Servers are stopped.

Have looked at your useful tutorial, but I don't think my current problems relate to more than simply adding records to the db - getting the data right is the next step!

Really frustrating this. I need to upgrade a php4 project and my phpdev setup is now too long in the tooth to cope. Hoped this would be a good alternative.
bannisa2
 
Posts: 7
Joined: 09. January 2008 22:17
Location: Abbots Langley, UK

Postby Izzy » 10. January 2008 02:00

My advise as I mentioned in my post above is not to try and do anything with the system database mysql or any of those already created in the phpMyAdmin database list, for obvious reasons as the user you are using to access and write new data may not have permissions to do what you want - user pma for example has read only access.

My suggestion of creating a database for your own use still stands and creating a user for that database with permissions for full access and a database user access password may eliminate these errors.

I am not familiar with this error and from the FAQ 2.8 mentioned most items are as they should be in the default Apache installation - this is why I asked if you had changed anything - but please read that linked FAQ in the error message and see if it makes any sense to you.

So I suppose the next line of attack might well be in doing a Google search for your error message and see if any one else on the Internet knows what's happening - or you could wait for some other forum member with experience of this issue to spot your post and provide a definitive solution - as you can guess my time is limited as this issue needs much more research because I am unable to replicate it for you.

Try checking out the XAMPP bug site to see if there is a known issue:
http://bugs.xampp.org/my_view_page.php

One of the developers pops in to the forums from time to time, in between coffee breaks perhaps, that may shine more light on the issue.

Just to add, I have known setting these two to have fixed some strange errors when developing, although I have my doubts in this case, but it will do no harm to try when only using localhost for developing - you can always revert if it changes nothing for you:
Turn On register_globals and turn Off safe_mode in your xampp\apache\bin\php.ini file.

Restart Apache and make a backup up of any ini or conf file before editing.

Not sure it will help but having just tried to read the php file in question I spotted a possible solution by doing the above configuration changes.

And last but not least, as I keep adding things as I come across them, go to:
http://localhost
and test all the menu items, as quite a few are database driven to make sure that MySQL is functioning as it should.

Also have you tried switching php to php 4 using the xampp\php-switch.bat file and selecting 4 to switch, but make sure you have stopped Apache and MySQL before switching, then try doing what you want again, being as you are wanting to do things php4 related?

You can always switch back again using the same procedure but select 5 from the options.

Bear in mind though, that php switching in XAMPP 1.6.5 may have a bug that has been pointed out in recent posts and has been reported to XAMPP Bugs - but by reverting to an older XAMPP version the bug appears not to be evident.
http://bugs.xampp.org/view.php?id=64
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby bannisa2 » 10. January 2008 22:44

Thank you for all your advice, and I am pleased to report that I have found the solution to this problem, although I am still trying to find a proper fix rather than a workaround.

The culprit was my ZoneAlarm Security Suite. It was blocking '3rd Party' Cookies that are used by phpmyAdmin.

I had already noted a warning that Cookies must be enabled past this point., but a Google search found a number of people saying this was quite normal and could be ignored. It is not, and it should not be!

To add to my confusion I had an additional problem that when I turned the ZoneAlarm cookie control off it made no difference. However, when I disabled ZoneAlarm completely, the cookie message disappeared and I had full functionality.

If anyone one else shares this problem, I found some information on removing corrupt files at http://www2.nohold.net/noholdcust542/prod_1/Articles55646/corruptlogs.html
which did the trick.

However, I cannot set up a custom profile for localhost and so I have e-mailed ZoneAlarm for information. In the meantime I have to temporarily turn off cookie control when I want to use phpmyAdmin.

At least I can now get back to the project - always assuming I can transfer my old mySQL databases to the new setup!

Thanks again.
bannisa2
 
Posts: 7
Joined: 09. January 2008 22:17
Location: Abbots Langley, UK


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 78 guests