Problems with Mysql

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problems with Mysql

Postby jimmyham » 05. January 2008 12:30

Hi Guys,

I am using the O'Reilly book "Learning PHP & MySQL". Having installed Apache and MySQL using XAMPP, I followed the instructions in the book to access MySQL.

viz: start up a command prompt and type in "mysql". This gave a "not a command or recognised name" error.
Question 1: how do I get round this?

I then tried XAMPP control panel, using the MySQL Admin button. This flashed up a status panel for a few seconds then a Login window, inviting me to specify a username/password of my choice. I chose my normal user and password. It seemed quite happy for a bit, but then a pop-up window popped up with the message "Access violation of address 10002593 in module 'LIBMYSQL.dll'. Read of address 00000000." This window then continued to pop-up every second or so until I deleted the running process winmysqladmin.exe. This stopped it but when I rebooted the messages started again immediately.

I suspect that I will now have to uninstall everything and start again, probably using the manual procedure documentd in the book.

I am using Windows XP Home fully updated using automatic update.

Question 2: Is there a way out?

Ta.
Jimmy Ham
jimmyham
 
Posts: 4
Joined: 02. January 2008 19:48

Postby Izzy » 05. January 2008 12:46

viz: start up a command prompt and type in "mysql". This gave a "not a command or recognised name" error.
Question 1: how do I get round this?

Did you cd to the xampp\mysql\bin directory to issue the mysql command?

For my installation I would issue this command at the prompt to get there:
cd c:\xampp\mysql\bin

This command at the prompt in the bin directory will give you all the mysql commands to use:
mysql -?
You will know that your command prompt is working when you see a huge list presented.



Does this post help with the other error - it seems to be a popular error being posted just lately:
http://community.apachefriends.org/f/viewtopi ... 088#113088

Seems to be Firewall related and maybe ZoneAlarm at a guess as this firewall seems to cause XAMPP some headaches not evident using other flavors.

BTW, winmysqladmin.exe is deprecated now and is not used - use mysqladmin.exe from a command console prompt (same as Q1) or the MySQL GUI phpMyAdmin which, in a Windows GUI environment, is obviously the preferred solution.
http://localhost/phpmyadmin
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby jimmyham » 06. January 2008 12:49

Hi Izzy,

Thanks for that. I tried the following:

rename mysqladmin.exe as mysqladmin.ex. This caused mysql to fail to start.

I then edited the config file as suggested in the suggested solution (first suggestion) and put back the .exe file. This seemed to work but when I booted up this morning it started all over again when I stupidly clicked on the Admin button again. I noticed Window traffic lights at the bottom of the screen, clicked on them and aske Windows (XP) to stop the tool. Everything is now OK. It seems the edit to the file stops mysqladmin from loading and using the traffic lights to kill the program (if you accidently run it) does the trick.

Now, I went into the Web admin tool phpmyadmin 2.11.3. It complained that I hadn't set a password for root, so was insecure.

I then went into privileges and added a password to user 127.0.0.1. Back to Home Page, same message. Try the 're-load privileges' button. No change. Back to edit privileges, this time user localhost, same password. Back to Home Page: Access Violation!

"Error
MySQL said:

#1045 - Access denied for user 'root'@'localhost' (using password: NO)"

I am now totally baffled. I suspect that the minotaur's maze is easier to navigate than mysql admin!

Any ideas? Ta!
Jimmy Ham
jimmyham
 
Posts: 4
Joined: 02. January 2008 19:48


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests