Help with mod_auth_mysql needed

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Help with mod_auth_mysql needed

Postby badrid » 04. January 2008 23:17

Hi All

I am trying to set up a directory so that you need to authenticate before you can view.

I have created the .htaccess file as follows:

AuthName "Your Protected Area"
AuthType Basic
Auth_MYSQL_Username *
Auth_MYSQL_Password *
Auth_MYSQL_DB users
Auth_MYSQL_Password_Table user_info
Auth_MYSQL_Username_Field user_name
Auth_MYSQL_Password_Field user_passwd
Auth_MYSQL_Encrypted_Passwords Off
Auth_MYSQL_Non_Persistent On
Auth_MYSQL_Empty_Passwords Off
require valid-user

The DB, tables and fields all exist and the username and password are fine, however i get this error message in the apache error.log:

[Fri Jan 04 22:14:47 2008] [alert] [client] C:/xampp/htdocs/xampp/.htaccess: Invalid command 'Auth_MYSQL_Username', perhaps misspelled or defined by a module not included in the server configuration

I have removed the # before the loadmodule mod_auth_mysql line in httpd.conf but i have not added any other config into any httpd files, i think this is where i am going wrong but am not sure.

Any advance would be much appreciated
Posts: 1
Joined: 04. January 2008 22:47

Postby KallistaAEnvarou » 05. January 2008 10:36

You could also do a comparison in your databases. That's what I do.
Posts: 126
Joined: 02. December 2007 17:33
Location: Cold Cold California

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 85 guests