access violation errorr

Problems with the Windows version of XAMPP, questions, comments, and anything related.

access violation errorr

Postby manicmike » 02. January 2008 23:29

When MySql starts as a service, The error I get is "access Violation at address 1002593 in module 'LIBMYSQL.dll" Read of address 00000000.

Please help. It errors every 2 seconds and it is frustrating :?:
manicmike
 
Posts: 1
Joined: 02. January 2008 23:24

Postby Izzy » 03. January 2008 02:18

After doing an exhaustive search at most of the MySQL authoritative addresses for a solution to this issue there doesn't seem to be a definitive answer anywhere to be found.

Here is something you can try that may help fix it for you:

Stop any XAMPP modules and uninstall any XAMPP services you may have running for now - you can always re-install the services after.

Check that there are no processes still running by using the Windows Task Manager selected from the context menu after right clicking on the Task Bar - there should be no apache processes and no mysqld processes showing in the Processes tab after you have stopped every thing and closed the XAMPP Control Panel.

Open xampp\apache\bin\php.ini file in your text editor and find these lines
Code: Select all
[MySQL]
; Allow or prevent persistent links.
mysql.allow_persistent = On

Change to look like this
Code: Select all
[MySQL]
; Allow or prevent persistent links.
mysql.allow_persistent = Off

Save the file and restart Apache and MySQL


Another method is to do this as well as the above edits:
Drag and drop into your text editor xampp\mysql\bin\my.cnf (it may just be called my)
Find this section
Code: Select all
# The MySQL server
[mysqld]

Add this to the section
max_connections = 200

Save the file and restart MySQL

Always make backups of conf and ini files before editing.

Please post back if this fix works for you so it might help others with the same problem.

Not much else I can suggest, so I wish you luck with it.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Rundle » 04. January 2008 03:03

When installing Xampp with mysql ran as a service off the bat doesn't prompt you and ask if you'd like that service unblocked through your windows firewall. Good idea to do that first.

Actually as long as I tried to run it as a service its then that it would generate the error.

Unfortunately for Mysql to work it has to be ran as a service. It appears every time I click the admin button in the Xampp control panel to check the mysql settings it sets off the error message.
Rundle
 
Posts: 1
Joined: 04. January 2008 02:58


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 68 guests