Local folder not found offline AGAIN

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Local folder not found offline AGAIN

Postby av4tarnz » 29. December 2007 01:48

I'm unable to get to my local folder again while offline, the only way to get to it is to go online and open it then go offline again. This is fine until I close my browser then I can't get to it again.
I can get to the 'localhost' folder which contains the files XAMPP without any problems.

Izzy helped me out last month with the same problem, the thread can be viewed here.

I've tried reinstalling XAMPP following what Izzy said in my previous thread and have got this in 'httpd-vhosts.conf':
Code: Select all
NameVirtualHost 127.0.0.1:80
.
.
.
.
<VirtualHost 127.0.0.1>
ServerName localhost
DocumentRoot "C:/Program Files/xampp/htdocs"
<Directory "C:/Program Files/xampp/htdocs">
Options Indexes FollowSymLinks Includes ExecCGI
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost 127.0.0.1>
ServerName server.loc
DocumentRoot "C:/Program Files/xampp/htdocs/server"
<Directory "C:/Program Files/xampp/htdocs/server">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Order Allow,deny
Allow from all
</Directory>
</VirtualHost>


I've got this in the bottom of my 'hosts' file:
Code: Select all
127.0.0.1       localhost
127.0.0.1       server.loc


Looking at the 'error.log' file in 'apache/logs', this is what it says:
Code: Select all
.
.
.
.
[Sat Dec 29 12:57:31 2007] [warn] pid file C:/Program Files/XAMPP/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat Dec 29 12:58:06 2007] [notice] Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.4 configured -- resuming normal operations
[Sat Dec 29 12:58:06 2007] [notice] Server built: Sep 21 2007 00:29:38
[Sat Dec 29 12:58:18 2007] [notice] Parent: Created child process 3424
[Sat Dec 29 12:58:20 2007] [notice] Child 3424: Child process is running
[Sat Dec 29 12:58:20 2007] [notice] Child 3424: Acquired the start mutex.
[Sat Dec 29 12:58:20 2007] [notice] Child 3424: Starting 250 worker threads.
[Sat Dec 29 12:58:20 2007] [notice] Child 3424: Starting thread to listen on port 443.
[Sat Dec 29 12:58:20 2007] [notice] Child 3424: Starting thread to listen on port 80.


If anyone can point out where I've gone wrong I'd really appreciate it.
Thanks
av4tarnz
av4tarnz
 
Posts: 9
Joined: 12. November 2007 03:28

Postby KallistaAEnvarou » 29. December 2007 04:53

What browser and version are you using?
KallistaAEnvarou
 
Posts: 126
Joined: 02. December 2007 17:33
Location: Cold Cold California

Postby Izzy » 30. December 2007 00:17

It is not possible to connect to http://localhost if you have set your browser (any flavor except Opera 9) to Work Offline.

In your browser's File menu de-select Work Offline and you will find you should be able to connect to http://localhost again - http://localhost is not usually available to anyone from the Internet (online) so it can always be assumed that you are always off line anyway when trying to connect to localhost - 127.0.0.1.


===========================================
1. The new DeskTopXampp Launch Control for XAMPP / XAMPPlite
Posted by Ridgewood available from Ridgewood'sDTX web site

2. Build Rich AJAX Applications - Faster
TIBCO General Interface Pro Edition but FREE and Open Source
Fully working with NO donations required to get a user/password
===========================================
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby av4tarnz » 30. December 2007 08:37

Izzy
I don't have 'Work Offline' ticked. I didn't even know it was there.

If I enter 'localhost/server' in the address bar while working offline it works, but entering 'server.loc' doesn't.
IE7 gives 'Address not valid' error when using 'server.loc' and FF gives 'Server not found Firefox can't find the server at www(.)server.loc'.
(The brackets don't appear, I just put them in to stop it showing as a link)
av4tarnz
 
Posts: 9
Joined: 12. November 2007 03:28

Postby Izzy » 30. December 2007 09:39

Sorry, I did not quite understand your issue but now you have included more detail, I believe I can see the problem.

Do not put dots between any of the entries in the vhost file or it will give you the error you had the last time - just copy and paste the below config over your other entry - remember No Dots!

I have just created a site on my server called server.loc and it works in all my 5 different browsers using the following configs without any issues at all.
NameVirtualHost *:80
# (important! no dots here just spaces only)

<VirtualHost *:80>
ServerName localhost
DocumentRoot "C:/Program Files/xampp/htdocs"
<Directory "C:/Program Files/xampp/htdocs">
Options Indexes FollowSymLinks Includes ExecCGI
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName server.loc
ServerAlias www.server.loc
DocumentRoot "C:/Program Files/xampp/htdocs/server"
<Directory "C:/Program Files/xampp/htdocs/server">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Order Allow,deny
Allow from all
</Directory>
</VirtualHost>

Move these entries to the very top of your host file so they are the first to be read by your system.
127.0.0.1 localhost
127.0.0.1 server.loc
127.0.0.1 www.server.loc


Save the files after editing and restart Apache - remember to make a backup first.
(Also delete your browser's cache before trying again).

Give that a try as it works for me without issue.

You should now be able to go to any of these by typing them in your browser:
server.loc
http://server.loc
www.server.loc
http://www.server.loc

BTW localhost is only accessible from your PC (off line) so no need to even mention that as it only confuses, as there is a Work Offline menu item in most browsers which has nothing to do with operating at localhost level.

Also to prevent a URI showing in the forum as a link just bold it like so:
www.server.loc
become no link after bolding
www.server.loc


===========================================
1. The new DeskTopXampp Launch Control for XAMPP / XAMPPlite
Posted by Ridgewood available from Ridgewood'sDTX web site

2. Build Rich AJAX Applications - Faster
TIBCO General Interface Pro Edition but FREE and Open Source
Fully working with NO donations required to get a user/password
===========================================
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby av4tarnz » 01. January 2008 05:45

Hi Izzy
I haven't put any dots between entries in my vhost file, I just did that in replies to this thread to suggest that there was entries between what I had altered. I won't do it in future posts to prevent confusion.

I've pasted the code you had in your last reponse to the repective files but there has been any change, I can still only get to my local folder using 'localhost/server'.

Thanks for your help so far
av4tarnz
av4tarnz
 
Posts: 9
Joined: 12. November 2007 03:28


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 57 guests