Access violation at address 10002593

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Postby nicknormal » 17. January 2008 21:14

djpentz,

thanks for your advice. but i can only get this to work with root/(no password), which is really un-secure. is there any other method anyone can think of to put password restriction on this module?

thanks for this thread!
nicknormal
 
Posts: 1
Joined: 17. January 2008 21:10

Postby jerdai » 06. February 2008 11:31

Thanks again to DVerhaaff, for figuring out how to get around the error.

As far as the password goes u can still put one, but i chose to use "MySQL Administrator" and "MySQL Query Browser" instead of win. After getting connected I was able to change the password from with in MySQL Administator. Hope this helps
jerdai
 
Posts: 1
Joined: 06. February 2008 11:20

Postby suokunlong » 06. February 2008 14:54

I'd got the same problem and I did as what he said and it is ok now.
I came across the problem after my re-installing of the XAMPP. I find that when the XAMPP is uninstalled,the .ini file is not deleted at all... so you have to edit the password if you have changed it the first time you installed.
suokunlong
 
Posts: 1
Joined: 06. February 2008 14:44

Postby Sinaida » 07. February 2008 20:14

Hallo,

sorry, mir geht es wie DVerhaaff - ich kann Englisch lesen und verstehen, aber nicht so gut in Worte fassen, was ich möchte :( Aber ich versuchs - lachen ist erlaubt :)

So here my problem in english :)

I've got the same problem, but I'm not fast enough to edit the my.ini file. There are only 2 seconds time for editing, than the admin window exits and one error popup after the other is shown.
Is there another solution for this problem?

Windows 2000 Prof, SP4

Thanks for your help in advance

Sina
Sinaida
 
Posts: 2
Joined: 07. February 2008 19:59

Postby Sinaida » 07. February 2008 20:39

No edit possible for my further posting :(

But I stopped the popups ... YEAH :twisted:

This thread was very helpful:
http://community.apachefriends.org/f/viewtopic.php?t=28380

The popups were stopped after deleting the password NO in the WINNT\my.ini file .

But this didn't stop the 2 second-edit-time problem for the winmysqladmin...

Sina

Edit: Now I see the edit-button... Sorry, normally I'm not a 'multi-poster'
Sinaida
 
Posts: 2
Joined: 07. February 2008 19:59

Postby Mainzelmann1 » 07. February 2008 21:35

It is such a pity. Have XAMPP there. Was lots of work for sure and is great. Neat packaging, easy installation, cares for security. But then, after the landig strip, engines already turned off, the front wheel breaks down. After having to drop it on my Mac because it was not possible to get it finally running, I have to dump it on the Vista machine also. Really a shame given all the work that has been consumed by it. Enough regret, back to the original packages (which do work).
Mainzelmann1
 
Posts: 4
Joined: 07. February 2008 21:30

Postby susi18 » 09. February 2008 17:37

Hallo zusammen,
hat jemand schon ne brauchbare Lösung gefunden?
So wäre Xampp leider unbrauchbar.
Müsste über die MySql Konsole nämlich ne größere Datenbank einspielen.
Oder gibts irgendwo ne ältere Version zum Download?
Damit solls nämlich keine Probleme geben.
susi18
 
Posts: 4
Joined: 09. February 2008 17:34

Postby susi18 » 09. February 2008 18:04

Sinaida wrote:This thread was very helpful:
http://community.apachefriends.org/f/viewtopic.php?t=28380

Sorry hat doch geklappt nach diesem Hinweis, danke.
susi18
 
Posts: 4
Joined: 09. February 2008 17:34

Postby Kasei » 12. February 2008 12:52

ok hier wie ich das Problem los wurde.
Nach Installation

1. starte apache , mysql starten

2. apache administration -> sicherheitscheck -> mysql benutzer passwort festlegen (oder hier http://localhost/security/xamppsecurity.php)

3. nun mysql administration starten und bei my.ini user=root und passwort das von euch gewählte passwort. eventuell startet auch ne abfrage wo ihr das festlegen könnt wenn ihr mysqladmin zumersten mal startet.
(weis jemand wie ich den usernamen von root auf etwas anderes änderen kann?)
falls die fehlermeldung zu schnell auftaucht, im windows verzeichnis solltet ihr die my.ini datei finden, könnt sie dann mit einem editor ändern.
Kasei
 
Posts: 1
Joined: 12. February 2008 12:42

Postby asafadi » 20. February 2008 02:36

Kasei wrote:ok hier wie ich das Problem los wurde.
Nach Installation

2. apache administration -> sicherheitscheck -> mysql benutzer passwort festlegen (oder hier http://localhost/security/xamppsecurity.php)


I don't know German, but I'm pretty sure Kasei has got the right idea.
XAMPP has a security script that will take care of these security issues for you.

I'll go step-by-step for the rookies, feel free to skip steps as needed.

  1. Open the XAMPP Control Panel Application.
    Make sure that Apache and MySql are running.
  2. Click on the Apache "Admin..." button.
  3. On the left-hand navigation list, click on the "Security" link under the "XAMPP" section.
    http://localhost/security/index.php
    This will open a separate tab/window titled "XAMPP SECURITY [Security Check 1.0]".
  4. After the table, click on:
    http://localhost/security/xamppsecurity.php
    This will take you to a page titled "Security console MySQL & XAMPP directory protection".
    This page will have 2 sections: "MYSQL SECTION: "ROOT" PASSWORD" and "XAMPP DIRECTORY PROTECTION (.htaccess)".
  5. In the first section, set the desired password for the "root" account username, then submit the form.


DONE!

At this point you have secured your MySql database using a password of your choosing (not the default or blank).
asafadi
 
Posts: 3
Joined: 03. January 2008 13:10
Location: Charlotte, NC, USA

Postby Mainzelmann1 » 20. February 2008 06:10

asafadi wrote:At this point you have secured your MySql database using a password of your choosing (not the default or blank).


Yes. And you have taken care tht all of a sudden you are floode with "Access violation at address 10002593" popups.
Mainzelmann1
 
Posts: 4
Joined: 07. February 2008 21:30

Postby asafadi » 20. February 2008 14:28

Mainzelmann1 wrote:Yes. And you have taken care tht all of a sudden you are floode with "Access violation at address 10002593" popups.


Right... I forgot to mention that! Good call..
asafadi
 
Posts: 3
Joined: 03. January 2008 13:10
Location: Charlotte, NC, USA

apache probs

Postby flattermann » 20. February 2008 17:19

hey na ;)
ich habe ein prob und hoffe ihr könnt mir helfen ...
wenn ich apache starten will in dem control teil ... dann kommt kurz running und dann wieder nichts dann ist es wieder aus und der sagt mir auch nicht das es stoppt ... habe auch schon mal neu installiert ... trotzdem nichts ...woran kann das liegen ? :cry:
hoffe um hilfe ;)
flattermann
flattermann
 
Posts: 2
Joined: 20. February 2008 14:41

Acces violation win mySQL

Postby JDO » 24. February 2008 11:50

i Had the same message over and over again every 3 seconds.

This is what you can do to make this go away for a longer time.

Open xampp en start mySQl Admigo to the tab Evironment (the first one)

look in the bottum left corner and en click the button "Set Sever Query Interval" Change this to 999 sec.
No it only pop ups every 999 sec when using the service.

JDO
JDO
 
Posts: 1
Joined: 24. February 2008 11:41

Postby Mainzelmann1 » 24. February 2008 16:43

Hey that's a great idea.
Should you once have a nail in your tire, will you pump it up all 999 seconds?
Mainzelmann1
 
Posts: 4
Joined: 07. February 2008 21:30

PreviousNext

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 82 guests