changing directory permissions

Problems with the Windows version of XAMPP, questions, comments, and anything related.

changing directory permissions

Postby shanehudg » 17. December 2007 22:44

Hi, I'm attempted to setup a local test environment for my web application on my laptop running Windows XP. I have XAMPP installed and is working properly as well as the rest of my webpage loaded and running correctly. However, my web application uses smarty templates which requires a certain directory to be writeable by the web server. I've tried using windows explorer and folder options to go in and remove the read only attribute but the setting is being enforced, I'm assuming, by Apache and I can't find where I can go in and change that setting. Any help that anyone could give me would be greatly appreciated.

Shane
shanehudg
 
Posts: 3
Joined: 17. December 2007 22:36

Postby Izzy » 17. December 2007 23:08

This is not possible on Windows Apache - this permissions request is aimed at Linux based Apache servers.

On Windows the permissions are defined by how you are logged on - as an administrator usually has full permissions.

Right click on a directory and select the Security tab if you are the Administrator for the relevant permission settings but usually you don't need to change anything here even for Smarty pants - I have Smarty installed on various web scripts and have had absolutely no permission issues at all, just ignore the reference to change permissions when installing.


===========================================
1. The new DeskTopXampp Launch Control for XAMPP / XAMPPlite
Posted by Ridgewood available from Ridgewood'sDTX web site

2. Build Rich AJAX Applications - Faster
TIBCO General Interface Pro Edition but FREE and Open Source
Fully working with NO donations required to get a user/password
===========================================
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby shanehudg » 17. December 2007 23:24

Windows is continuing to mark the directory as read only. When I right click on the folder, there is no security tab. There is a sharing and security option but it only deals with sharing the folder over a local network. When I run the application, I get the error message telling me that apache does not have write access to the necessary directory. Can you give me any guidance on how to do this? FYI, I am logged in as administrator, it is the only user account I have on here so it automaticly logs in as admin.
shanehudg
 
Posts: 3
Joined: 17. December 2007 22:36

Postby Izzy » 17. December 2007 23:37

Without seeing the actual error message I can't help you.

Check your error logs.
xampp\apache\logs\error.log

You can't change permissions on a directory in Windows if it is grayed out, only on individual files and there is no need even to do that in XAMPP - I take it you are using XP Home but you didn't say, as there are many restrictions that are not evident in XP Pro re administration facilities.

Apache on Windows has no means to change any Windows file or directory permissions at all, period, so that area is now closed - only on *nix systems is this possible - you need to address your issues with file permissions on Windows installations with the script's authors not here on XAMPP.


[EDIT]
I have just perused the Smarty site (you obviously have not) and everything you are trying to do, but failing in, is outlined in much detail through out their site - so the Smarty site is the place to get answers for your issues.

BTW Apache will not write to any file or directory outside the DocumentRoot directory, for security reasons, and if this directory that is giving you permission issues is out side the DocumentRoot then Buckley's - but as I pointed out above their web site has all the answers you need.
[/EDIT]


===========================================
1. The new DeskTopXampp Launch Control for XAMPP / XAMPPlite
Posted by Ridgewood available from Ridgewood'sDTX web site

2. Build Rich AJAX Applications - Faster
TIBCO General Interface Pro Edition but FREE and Open Source
Fully working with NO donations required to get a user/password
===========================================
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby shanehudg » 19. December 2007 00:01

You are absolutely right. I have not read the smarty website. I don't even know what it is. All I knew is that the PHP code I am using, uses smarty templates and that is what the internal error messages I was getting state what the problem is. I know that it isn't an internal Windows issue because I can change the setting but as soon as I close the properties window, the read only setting is reapplied. The setting is being applied to the entire document root folder and all it's subfolders which is why my first thought was possibly in the apache configuration. You said that xampp for windows has no such setting so that cleared that up (thank you) my next thought was to double check my user account settings. I'm logging in under a self created account that has full administrator privilages (according to the computer management tool under administrative tools on the control panel). Windows help tells me that the user account named administrator remains active but is hidden once a user defined administrator account is created. My next thought was that filezilla ftp server may be enforcing the setting but I've uninstalled that as a service and the problem is still there. If you found the solution on the smarty website, I would be more than happy to go there to resolve this if you would point me in that direction. I'm not accusing XAMPP or Apache Friends of any failure, I'm merely posting here as a starting point to try and find the root of the problem since I believe it to be a communication problem due to my lack of knowledge in configuring these kind of systems. I'm teaching myself here and sometimes you just have to get a little advice from someone more experienced than yourself.
shanehudg
 
Posts: 3
Joined: 17. December 2007 22:36


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 66 guests