I can't create table in phpMyAdmin

Problems with the Windows version of XAMPP, questions, comments, and anything related.

I can't create table in phpMyAdmin

Postby in2mobile » 16. December 2007 20:52

I am trying to create a table inside of the "test" database that comes with PhpMyAdmin. I set up the fields and everything, but when I try to save the table a message pops up and reads "This is not a Number". I don't understand why this is happening. Here is how I have the table set up.

Field Type Length/Values Collation
----- ------ ----------------- ------------

id Varchar Utf8_unicode_ci

email Varchar 50 Utf8_unicode_ci

password Varchar 50 Utf8_unicode_ci

site Varchar Utf8_unicode_ci

logeden Int Utf8_unicode_ci

Attributes Null Default Extra
----------- ------ ---------- -------
not null auto_increment

not null 50

not null 50


not null

Storage Engine Collation
------------------ -------------
MyISAM utf8_unicode_ci

these are the values that I have. Any help with figuring out why I can't save this table is greatly appreciated.
Posts: 5
Joined: 16. December 2007 08:17

Postby Scory » 17. December 2007 13:43

It says what it means "This is not a number":

id Varchar Utf8_unicode_ci

You declared id as "auto_increment" which means, it MUST be a number (a digit), but you declared it as a string ("varchar"). You must change it to "int".


Postby in2mobile » 18. December 2007 10:08

Scory thanks for the advice. I seem to not be able to get down how to exactly use phpmyadmin. Are their any good tutorials out there?
Posts: 5
Joined: 16. December 2007 08:17

Postby skuipers » 23. December 2007 08:29

Why don't you have a look at the phpMyAdmin website?
Posts: 99
Joined: 21. January 2005 16:27
Location: The Netherlands

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 95 guests