Another httpd.conf File

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Postby KallistaAEnvarou » 24. December 2007 10:09

In your bbs/index.php file, type this:

echo nl2br(print_r($_SERVER))

Look through and see if you can get any clues. Specifically look at $_SERVER[SCRIPT_FILENAME], as it should tell you what you want to know.

geekmaster wrote:There is nothing wrong with my .htaccess code as you can see.


I didn't say there was anything wrong with it, at least syntax-wise, but I'm not too familiar with .htaccess coding (and I'm too sick to be able to research it research effectively), so I don't know what all that stuff does. I was just wondering if the logic of the .htaccess file might be the culprit.
KallistaAEnvarou
 
Posts: 126
Joined: 02. December 2007 17:33
Location: Cold Cold California

Postby geekmaster » 24. December 2007 10:19

You mean put "echo nl2br(print_r($_SERVER))" in my bbs/index.php file?
It wont go to my bbs/index.php file.
It just goes to my htdocs/index.php file

it even does the same for htdocs/mail/index.php
it wont go to these directories when I type either URL.
You can even try it for urself.
geekmaster
 
Posts: 23
Joined: 13. December 2007 14:13

Postby KallistaAEnvarou » 24. December 2007 11:03

Actually, I meant echo nl2br(porint_r($_SERVER,1))...

So put it in your /index.php file and tell me what you get.

Also, why don't you try temporarily moving your .htaccess files to a different location (your desktop, for example) and trying then?
KallistaAEnvarou
 
Posts: 126
Joined: 02. December 2007 17:33
Location: Cold Cold California

Postby geekmaster » 24. December 2007 11:07

works with
Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
ServerName localhost
DocumentRoot "D:/server/htdocs"
<Directory "D:/server/htdocs">
Options Indexes FollowSymLinks Includes ExecCGI
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName mail.347media.com
ServerAlias www.mail.347media.com
DocumentRoot "D:/server/htdocs/mail"
<Directory "D:/server/htdocs/mail">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Order Allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName forums.347media.com
ServerAlias www.forums.347media.com
DocumentRoot "D:/server/htdocs/bbs"
<Directory "D:/server/htdocs/bbs">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Order Allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName 347media.com
ServerAlias www.347media.com
DocumentRoot "D:/server/htdocs"
<Directory "D:/server/htdocs">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Order Allow,deny
Allow from all
</Directory>
</VirtualHost>

Thanks for your help
geekmaster
 
Posts: 23
Joined: 13. December 2007 14:13

Postby KallistaAEnvarou » 24. December 2007 11:09

But now I can't access http://forums.347media.com or even http://www.forums.347media.com because I get:

You tried to access the address http://forums.347media.com/, which is currently unavailable. Please make sure that the Web address (URL) is correctly spelled and punctuated, then try reloading the page.
Make sure your Internet connection is active and check whether other applications that rely on the same connection are working.
Check that the setup of any Internet security software is correct and does not interfere with ordinary Web browsing.
If you are behind a firewall on a Local Area Network and think this may be causing problems, talk to your systems administrator.
Try pressing the F12 key on your keyboard and disabling proxy servers, unless you know that you are required to use a proxy to connect to the Internet. Reload the page.
Need help?
Open the Opera Help.
Go to Opera's on-line support desk.

The mail subdomain works now, though.
KallistaAEnvarou
 
Posts: 126
Joined: 02. December 2007 17:33
Location: Cold Cold California

Postby geekmaster » 24. December 2007 11:14

http://forums.347media.com works for me, but www.http://forums.347media.com doesn't. should I do something in .htaccess?
geekmaster
 
Posts: 23
Joined: 13. December 2007 14:13

Postby KallistaAEnvarou » 24. December 2007 11:15

Neither of them work for me, so...I don't know...
KallistaAEnvarou
 
Posts: 126
Joined: 02. December 2007 17:33
Location: Cold Cold California

Postby geekmaster » 24. December 2007 11:22

KallistaAEnvarou wrote:Neither of them work for me, so...I don't know...
thats weird.
did u clear ur cache before you tried http://forums.347media.com/ ?
geekmaster
 
Posts: 23
Joined: 13. December 2007 14:13

Postby geekmaster » 24. December 2007 11:37

I dont get it.
How could it be working for me and not for anyone else. 347media.com works for everyone and im sure port 80 isnt blocked.
http://gallery.ny-dev.com/showphoto.php?photo=1346
I dont understand.
What can this be?
geekmaster
 
Posts: 23
Joined: 13. December 2007 14:13

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 57 guests