Apache stopped working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache stopped working

Postby ryonker » 07. December 2007 19:57

I installed apache, php & mySQL using the xampp installer. Everything was working fine with no problems for the last two weeks. Now out of nowhere I can't view my pages or connect to a DB. I changed nothing on my computer myself. Here is the error that I get. I am running Windows Vista Business and Dreamweaver CS3.

Object not found!

The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.
Error 404
localhost
12/07/07 10:55:11
Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.4

Can anyone help me? I tried uninstalling and reinstalling. I do not have IIS running on my machine. The control panel show that both apache and mySQL are running.

Thanks,
Robert
User avatar
ryonker
 
Posts: 19
Joined: 07. December 2007 19:45
Location: California

Postby KallistaAEnvarou » 07. December 2007 20:10

That means Apache is working. Are you trying to connect to a subfolder?
KallistaAEnvarou
 
Posts: 126
Joined: 02. December 2007 17:33
Location: Cold Cold California

Postby ryonker » 07. December 2007 20:34

Yes. I have not changed the structure of my website since I first had it working. Everything is inside xampp\htdocs folder inside my folder for my website. I tried testing my connection in dreamweaver to my DB and that gives me the same error. When I try to view the index.html in browser I get the error saying that the object is not found. I check the setup of where the files are located and they are correct but they are still not being found.
User avatar
ryonker
 
Posts: 19
Joined: 07. December 2007 19:45
Location: California

Postby KallistaAEnvarou » 07. December 2007 20:38

No, Apache is working, or else you'd get the browser-defined server-not-found error. Now, when you try to do stuff in your folder, what URL appears in the address box when you get this error?
KallistaAEnvarou
 
Posts: 126
Joined: 02. December 2007 17:33
Location: Cold Cold California

Postby ryonker » 07. December 2007 20:43

Here is the address directly from the browser:

http://localhost/tce_marketing/index.html

My testing server is set up on my local machine that I am doing to work on.
User avatar
ryonker
 
Posts: 19
Joined: 07. December 2007 19:45
Location: California

Postby KallistaAEnvarou » 07. December 2007 20:47

Are you using .htaccess in that folder?

After changing the extension to .php, try typing this:

<?php
echo '$_SERVER[REDIRECT_STATUS]=', $_SERVER[REDIRECT_STATUS];
?>

and tell me what you get
KallistaAEnvarou
 
Posts: 126
Joined: 02. December 2007 17:33
Location: Cold Cold California

Postby ryonker » 07. December 2007 20:54

I tried opening one of my php pages in the browser and get the same error. I put the code that you sent in the top of my page in code view and still get the same error. I am fairly new to all this so I apologize if I have put this in the wrong spot. Let me know what corrections that I need to do if any for where the code is sitting.
User avatar
ryonker
 
Posts: 19
Joined: 07. December 2007 19:45
Location: California

Postby KallistaAEnvarou » 07. December 2007 20:58

Oh wait...if it doesn't recognize the file, it's not going to print anything...

Again, do you use .htaccess? It could be interefering.
KallistaAEnvarou
 
Posts: 126
Joined: 02. December 2007 17:33
Location: Cold Cold California

Postby ryonker » 07. December 2007 21:02

As far as I know I do not. Is there a way to check for that and if so how to disable/delete it?
User avatar
ryonker
 
Posts: 19
Joined: 07. December 2007 19:45
Location: California

Postby KallistaAEnvarou » 07. December 2007 21:05

Just look for the file. If you see it, delete it.
KallistaAEnvarou
 
Posts: 126
Joined: 02. December 2007 17:33
Location: Cold Cold California

Postby ryonker » 07. December 2007 21:16

I tried looking for it and could not find a folder htaccess. I tried testing my DB connection in DW and here is the error that I get, I don't know if this helps:

HTTP Error Code 404 File Not Found. Here are some possible reasons
for the problem

1) There is no testing server running on the server machine.
2) The testing server specified for this site does not map to the http://localhost/tce_marketing/_mmServe ... HTTPDB.php URL. Verify that the URL Prefix maps to the root of the site.
User avatar
ryonker
 
Posts: 19
Joined: 07. December 2007 19:45
Location: California

Postby KallistaAEnvarou » 07. December 2007 21:20

.htaccess is not a folder. It's a file. But since you don't know what it is, you probably don't have it. Now, when you type http://localhost in your browser, what happens?
KallistaAEnvarou
 
Posts: 126
Joined: 02. December 2007 17:33
Location: Cold Cold California

Postby ryonker » 07. December 2007 21:22

I get the welcome screen for xampp for windows.
User avatar
ryonker
 
Posts: 19
Joined: 07. December 2007 19:45
Location: California

Postby KallistaAEnvarou » 07. December 2007 21:25

OK, then your Apache is, indeed, working.

Now what happens if you type just http://localhost/tce_marketing?
KallistaAEnvarou
 
Posts: 126
Joined: 02. December 2007 17:33
Location: Cold Cold California

Postby ryonker » 07. December 2007 21:28

I get the original error:

Object not found!

The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.
Error 404
localhost
12/07/07 12:27:39
Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.4
User avatar
ryonker
 
Posts: 19
Joined: 07. December 2007 19:45
Location: California

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests