Apache starts and then stops

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache starts and then stops

Postby nickninety » 05. December 2007 09:20

After installing XAMPP with no problems the control panel applet showed Apache starting on request and then stopping after a few seconds.

The documentation says to check the critical ports are free (and they were), stop antivirus and firewall (no change). However the error log said 'setup_inherited_listeners()'- so there was something.

And here is the solution (at least for me):

Start>Control panel> Network connections>Internet connection>Properties>Settings

In there is DemonwarePortMapping. I unticked this and Apache sprang to life!

I can only find mention of this service on three internet sites and no file with this name on my PC

Does anyone know what it does or what installed it?

**********************************************
Here is the error log in case it helps anyone else find this entry:

[Tue Dec 04 22:19:04 2007] [notice] Server built: Sep 21 2007 00:29:38
[Tue Dec 04 22:19:04 2007] [notice] Parent: Created child process 2788
[Tue Dec 04 22:19:06 2007] [notice] Child 2788: Child process is running
[Tue Dec 04 22:19:06 2007] [crit] (OS 10022)An invalid argument was supplied. : Child 2788: setup_inherited_listeners(),
WSASocket failed to open the inherited socket.

(note that the Child number changes each time).
Nick.
nickninety
 
Posts: 3
Joined: 05. December 2007 08:48
Location: Scotland

Postby Izzy » 05. December 2007 10:21

nickninety wrote:And here is the solution (at least for me):
The solution is very much unique to you.

nickninety wrote:Start>Control panel> Network connections>Internet connection>Properties>Settings

In there is DemonwarePortMapping. I unticked this and Apache sprang to life!

I can only find mention of this service on three internet sites and no file with this name on my PC

Does anyone know what it does or what installed it?

I have never heard of this setting and must be unique to your system.

A good indication that it is something only related to your PC is by doing a search of all forums on this board for demonware and zilch is returned.

What OS are you running?

Has this anything to do with your router, as DemonwarePortMapping was/is router related but I believe Demonware was bought out by Activision/TrendMicro perhaps?

I can assure you it has nothing to do with XAMPP or it's installation at all and is very much related only to your PC and something you installed at some time or perhaps was installed by some malware - who knows but you.

This Google may have some clues perhaps and the bit I read about it seemed to be related to gaming.

And this Google search for demonware gives who and what it is.


===========================================
1. The new DeskTopXampp Launch Control for XAMPP / XAMPPlite
Posted by Ridgewood available from Ridgewood'sDTX web site

2. Build Rich AJAX Applications - Faster
TIBCO General Interface Pro Edition but FREE and Open Source
Fully working with NO donations required to get a user/password
===========================================[/quote]
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby nickninety » 05. December 2007 17:50

Thanks for the reply.

I am running XP SP2 and have a Netgear router so if it was anything to do with those then there would be more posts as you say.

Looking at the searches you posted it seems likely to be a game that has installed it.
I guess the take away is that even if there is nothing shown on the portcheck or netstat there can still be a listener and Network Connections is a good place to start looking.
Nick.
nickninety
 
Posts: 3
Joined: 05. December 2007 08:48
Location: Scotland


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests