sendmail_from

Problems with the Windows version of XAMPP, questions, comments, and anything related.

sendmail_from

Postby SirChick » 01. December 2007 18:09

How do i turn my mail settings on so that it will work
sendmail_from no value no value
sendmail_path no value no value



At the mome it says that ^ and i get this error:


Warning: mail() [function.mail]: "sendmail_from" not set in php.ini or custom "From:" header missing in C:\xampp\htdocs\test4.php on line 8


How do you turn it on :S
SirChick
 
Posts: 68
Joined: 19. June 2007 15:03
Operating System: Windows 7 64 bit

Postby Wiedmann » 01. December 2007 19:32

Warning: mail() [function.mail]: "sendmail_from" not set in php.ini or custom "From:" header missing in C:\xampp\htdocs\test4.php on line 8

a) set the sendmail_from in php.ini
b) or set a "From: ..." header in the 3rd parameter from mail().
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby SirChick » 01. December 2007 19:53

How do you do a) ? i've been trying work out how but have no idea..
SirChick
 
Posts: 68
Joined: 19. June 2007 15:03
Operating System: Windows 7 64 bit

Postby Wiedmann » 01. December 2007 20:00

How do you do a)

- open "php.ini" in your editor
- search the line with "sendmail_from"
- remove the ";"
- change the email to a correct one
- save the "php.ini"
- restart Apache
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests