eclipse PHP plugin & MySQL

Problems with the Windows version of XAMPP, questions, comments, and anything related.

eclipse PHP plugin & MySQL

Postby Daria » 28. November 2007 00:11

Dear all,

I was wondering if anyone is using eclipse php plugin - PDT ( If yes, could anyone share how to set the connection to a MySQL db???

I've used XAMPP for Windows (

Many thanks in advance,
Posts: 2
Joined: 27. November 2007 20:43

Postby Izzy » 28. November 2007 02:06 ... 10175.html

Google is also your friend.

Eclipse, I believe, is Java based and so you need a MySQL JDBC driver to connect.

Eclipse is no way connected in any form with XAMPP so you should direct your questions to the appropriate Eclipse PDT resources some of which I have included links to above to get the correct and official information.

You could be waiting some time for a reply in this forum but in the mean time doing some research on your own might be much quicker and rewarding.

Thanks for the link but I think we already know about it. :roll:

1. The new DeskTopXampp Launch Control for XAMPP / XAMPPlite
Posted by Ridgewood available from Ridgewood'sDTX web site

2. Build Rich AJAX Applications - Faster
TIBCO General Interface Pro Edition but FREE and Open Source
Fully working with NO donations required to get a user/password
Posts: 3344
Joined: 25. April 2006 17:06

Postby Daria » 02. December 2007 17:16

Doh... silly me, should have checked there as well! Thanks a lot for the links :) It's all connected now yay!
Posts: 2
Joined: 27. November 2007 20:43

Postby dlmaster » 04. December 2007 12:15


Can you tell me how you connect it? I do not quite get what it is said. How should I install them? I'm using phpEclipse 1.1.8, Eclipse version 3.2.0 and XAMPP version 1.4.9. I plan to use the Apache that is available in XAMPP but the mySQL separately... Should I use the jdbc or the odbc? Previously I have used Eclipse and mySQL for jsp project. It works fine previously but in php I'm having this problem.

Warning: mysql_connect() [function.mysql-connect]: Client does not support authentication protocol requested by server; consider upgrading MySQL client in C:\xampp-win32-1.4.9\xampp\eclipse\workspace\PB\reg_form.php on line 8

My previous mySQL (mysql 5.0) is installed in Program Files. XAMPP is installed in C. I had a copy of eclipse with the workspace (containing my php project) in XAMPP folder. Previously I installed eclipse in Program Files too...
Thank you...
Posts: 19
Joined: 12. November 2007 05:54

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 71 guests