Don't load localhost - Please, HELP!!!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Don't load localhost - Please, HELP!!!

Postby vsPointer » 14. November 2007 15:25

A month ago installed XAMP. I'm make all configure and everything worked perfectly.

Yesterday installed MSVS 2005.

Now run XAMP - no problems.
I'm try to open the address. The browser loaded indefinitely, but Apache eat 80% memory. :cry:

why not work and how to make all workable?

---
sorry for my English :oops:
vsPointer
 
Posts: 4
Joined: 14. November 2007 15:02

Postby Izzy » 14. November 2007 17:09

Uncomment this line in your httpd.conf file:
#Win32DisableAcceptEx

So it looks like this:
Win32DisableAcceptEx

Add this line to the bottom of your httpd.conf file if it does not exist:
Win32DisableAcceptEx

xampp\apache\conf\httpd.conf

Save the file after you make the changes, then restart Apache.
Make a backup of the httpd.conf file before making any changes so you can revert if you make a typo.

XAMPP for Windows FAQ
http://www.apachefriends.org/en/faq-xam ... s.html#cpu


===========================================
1. The new DeskTopXampp Launch Control for XAMPP / XAMPPlite
Posted by Ridgewood available from Ridgewood'sDTX web site

2. Build Rich AJAX Applications - Faster
TIBCO General Interface Pro Edition but FREE and Open Source
Fully working with NO donations required to get a user/password
===========================================
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby vsPointer » 15. November 2007 06:31

the row added. file saved. Apache restarted, but no helped :cry:
vsPointer
 
Posts: 4
Joined: 14. November 2007 15:02

Postby Izzy » 15. November 2007 06:59

We need much more detail now.
Try and start Apache using the xampp\apache_start.bat file.

Paste here what errors it gives in detail.

Double click on xampp\xampp-portcheck.exe and paste the details here.

To copy and paste click on the little icon in the top left corner of the console window and select the edit menu - you will find the mark/copy/paste menu items there.

Also it could be related to your firewall - try disabling it temporarily then retry Apache.
http://community.apachefriends.org/f/viewtopic.php?t=15892

ZoneAlarm has been known to give XAMPP some problems so disable that temporarily if you have it installed and running and then try Apache again.

It will be a process of illumination to find what is causing your issues and as much info as you can give will help, as we here can't see what is happening or how you are configured.


===========================================
1. The new DeskTopXampp Launch Control for XAMPP / XAMPPlite
Posted by Ridgewood available from Ridgewood'sDTX web site

2. Build Rich AJAX Applications - Faster
TIBCO General Interface Pro Edition but FREE and Open Source
Fully working with NO donations required to get a user/password
===========================================
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby vsPointer » 15. November 2007 10:36

this message from apache_start.bat:
"Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
[Thu Nov 15 11:34:05 2007] [notice] Disabled use of AcceptEx () WinSock2 API"

this message from from apacha error.log:
"[Wed Nov 14 180816 2007] [error] (OS 10022 )??????? ???????????? ????????. Child 1716 Encountered too many errors accepting client connections. Possible causes dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive."

but the page is not loaded :(
vsPointer
 
Posts: 4
Joined: 14. November 2007 15:02

Postby Izzy » 15. November 2007 11:14

Again, double click on xampp\xampp-portcheck.exe and paste the details here - are all the ports that XAMPP uses showing as free?

Is there an error.log entry just after you try and start Apache because the 2 items you pasted are on different days and the error message was generated before you added the Win32DisableAcceptEx to the httpd.conf file?
[Thu Nov 15 11:34:05 2007] [notice] Disabled use of AcceptEx () WinSock2 API

[Wed Nov 14 180816 2007] [error] (OS 10022 )...

Adding Win32DisableAcceptEx should have fixed the error you pasted.

This error looks strange
(OS 10022 )??????? ???????????? ????????.
Is that exactly how it appeared in your log file?
Does it appear again just after you try and start Apache?
(OS 10022) = An invalid argument was supplied.

Did you temporarily deactivate your firewall and try to start Apache again?

If all else fails and we can't find the cause of this then some suggest that you may find uninstalling XAMPP, following the readme_en.txt file, and then installing again might fix this issue - This problem appeared after you installed MSVS 2005, perhaps there is a conflict that I am unaware of with what ever this is.

Have you tried uninstall MSVS 2005 to see if Apache starts to work again?


===========================================
1. The new DeskTopXampp Launch Control for XAMPP / XAMPPlite
Posted by Ridgewood available from Ridgewood'sDTX web site

2. Build Rich AJAX Applications - Faster
TIBCO General Interface Pro Edition but FREE and Open Source
Fully working with NO donations required to get a user/password
===========================================
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby vsPointer » 15. November 2007 13:17

double click on xampp\xampp-portcheck.exe and paste the details here

xampp\xampp-portcheck.exe opened and immediately closed. :(

original error.log size of 180 MB. I can not open it.
I created a new error.log. Apache launched and stopped.
here is the content logs:
"
[Thu Nov 15 13:58:08 2007] [crit] (22) Invalid argument: unable to replace stderr with error_log
[Thu Nov 15 13:58:08 2007] [crit] (2) No such file or directory: unable to replace stderr with / dev / null
[Thu Nov 15 13:58:12 2007] [crit] (22) Invalid argument: unable to replace stderr with error_log
[Thu Nov 15 13:58:12 2007] [crit] (2) No such file or directory: unable to replace stderr with / dev / null
[Thu Nov 15 13:58:15 2007] [notice] Apache/2.2.4 (Win32) DAV / 2 mod_ssl/2.2.4 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.3 configured -- resuming normal operations
[Thu Nov 15 13:58:15 2007] [notice] Server built: Mar 5 2007 11:23:00
[Thu Nov 15 13:58:15 2007] [notice] Parent: Created child process 2800
[Thu Nov 15 13:58:15 2007] [notice] Disabled use of AcceptEx () WinSock2 API
[Thu Nov 15 13:58:19 2007] [notice] Child 2800: Child process is running
[Thu Nov 15 13:58:19 2007] [notice] Child 2800: Acquired the start mutex.
[Thu Nov 15 13:58:19 2007] [notice] Child 2800: Starting 250 worker threads.
[Thu Nov 15 13:58:19 2007] [notice] Child 2800: Listening on port 443.
[Thu Nov 15 13:58:19 2007] [notice] Child 2800: Listening on port 80.
"
Did you temporarily deactivate your firewall and try to start Apache again?

I even deleted the firewall at the time

This problem appeared after you installed MSVS 2005 ...

unfortunately, I can not uninstall MSVS2005. I need it equally as XAMPP.

:idea: most likely I will be able to solve the problem by install XAMPP to another machine :-\
vsPointer
 
Posts: 4
Joined: 14. November 2007 15:02


Return to XAMPP for Windows

Who is online

Users browsing this forum: hthnightwolf and 69 guests