Cannot start session without errors, please check errors giv

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Cannot start session without errors, please check errors giv

Postby jmichae3 » 12. November 2007 09:55

new installation, and out of the box, neither WAMP 's phpmyadmin has worked, nor XAMPP.
phpMyAdmin - Error
Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.

log shows:
[Mon Nov 12 00:24:01 2007] [error] [client 127.0.0.1] PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: open(C:\\DOCUME~1\\Jim\\LOCALS~1\\Temp\\php\\session\\sess_gjvi99bko7q0592gb0gcrhsg87, O_RDWR) failed: No such file or directory (2) in C:\\xampp\\phpMyAdmin\\libraries\\session.inc.php on line 89, referer: http://localhost/xampp/navi.php
[Mon Nov 12 00:24:01 2007] [error] [client 127.0.0.1] PHP Warning: Unknown: open(C:\\DOCUME~1\\Jim\\LOCALS~1\\Temp\\php\\session\\sess_gjvi99bko7q0592gb0gcrhsg87, O_RDWR) failed: No such file or directory (2) in Unknown on line 0, referer: http://localhost/xampp/navi.php
[Mon Nov 12 00:24:01 2007] [error] [client 127.0.0.1] PHP Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (C:\\DOCUME~1\\Jim\\LOCALS~1\\Temp\\php\\session) in Unknown on line 0, referer: http://localhost/xampp/navi.php


php.ini has
session.save_path = "C:\xampp\tmp"

tried switching to version 4 php.

changed the permissions of the tmp directory so it has full permissions on every account (could not change owner) & turned off the readonly attribute.

these are the common fixes I have seen. once in russian via google I saw mcrypt.dll mentioned at the end of a thread.
nothing I have seen yet on any forum has worked. so far. I'm still digging. This is the latest version of xampp, a la Nov 12, 2007.

I finally figured it out. the installer is not creating
C:\Documents and Settings\Jim\Local Settings\Temp\php\session


C:\Documents and Settings\Jim\Local Settings\Temp
already exists.

then phpmyadmin complains about mysql not being loaded properly.
to fix this, switch PHP to version 4.

this should have been done in the installer.
jmichae3
 
Posts: 39
Joined: 12. November 2007 09:41
Operating System: win7-64-sp1-ult-retail

Postby sari42 » 13. November 2007 16:09

session.save_path = "c:\windows\temp"
in your php.ini (and restarting the webserver) should work (php must have modify rights there). Are you sure that you edited the right php.ini? Ask <?php phpinfo(); ?> for the location and the actual setting of session.save_path .
____

mcrypt is only needed for "cookie" login,
try auth_type "http" instead.
sari42
 
Posts: 800
Joined: 27. November 2005 18:28


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 28 guests