Netgear Router Login =[

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Netgear Router Login =[

Postby wint3r » 03. November 2007 17:28

Ok, heres the scenario.
I've installed xampp Fine, no problems. <-[When on server, and webpage Loads, i go to status, Says all Are working.]

I've put a website it htdocs.
I've Re-directed ports 80 in router, In and out allowed.
My connection:
Broadband -> Netgear Router -> Server connected though LAN, with a set Network IP [192.168.0.11]
Apache Running.
Set up using "no-ip.org" <- says its working fine.

If i open it on the server, It shows the pages, No Problems
If i open it on my laptop, It goes to the Router Config!
If i open it on my mates computer, It just comes up with the usual IE Page:
"Internet Explorer cannot display the webpage

Most likely causes:
You are not connected to the Internet.
The website is encountering problems.
There might be a typing error in the address."

It sucks... any help?
i think it must be to do with my router, but... I dont know what! <- Help

will it help to have another router:
Broadband -> New router[Open to the world] -> Server
Broadband -> New router[Open to the world] -> Old router -> Home Network.

Help will be appreciated =]

Thanks, Wint3r =]
wint3r
 
Posts: 1
Joined: 03. November 2007 16:53

Postby LooseCannon » 06. November 2007 13:34

Hello and welcome wint3r.

Lots of info, but I'm not clear about the network. Where are the server, laptop and PC in relation to each other and the router? What ip network(s) are the laptop and PC on, ie 192.168.0.xx or another? If 'another', then are they outside the router and getting in over broadband.

Is no-ip.com registered (FQDN)? Is it http://www.no-ip.com/? Pinging www.no-ip.com gives a different ip, but the 192.168.. ip you stated is your internal address?

Fast fix for inside the network: Add "192.168.0.11 no-ip.com" (without the speech marks) to the host file on every machine to access the site. That file is here - C:\WINDOWS\system32\drivers\etc. It has _no_ suffix, so right click and open with, say NotePad or other text editor. Ensure you save the file withOUT .txt on the end.

I guess the laptop finds the router config page because it's the default gateway and the laptop doesn't know where else to find no-ip.com. Guessing again, your mate's PC is on another metwork and it has no idea where/what no-ip.com is.
User avatar
LooseCannon
 
Posts: 162
Joined: 18. September 2007 12:07
Location: Hampshire, UK


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 59 guests