My htdocs folder is missing - can't create new?! help!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

My htdocs folder is missing - can't create new?! help!

Postby shizumexx » 30. October 2007 15:50

Hello

I downloaded xampplite and didn't get any folder called "htdocs", so I downloaded the full xampp and installed it.. still no "htdocs", I try to create a new one called htdocs but it says it already exists, and i know it's not invisible or anything.. ive tried writing C:\program\xampp\htdocs .. says there is no such folder.

Anyone can help me, or tell me if there is a way to redirect to another folder?

Thanks!!!
mike
shizumexx
 
Posts: 9
Joined: 30. October 2007 15:46

Postby Wiedmann » 30. October 2007 16:18

I downloaded xampplite and didn't get any folder called "htdocs",

Not really possible. (The XAMPP demopages are in a subfolder of this folder).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby shizumexx » 30. October 2007 16:39

Wiedmann wrote:
I downloaded xampplite and didn't get any folder called "htdocs",

Not really possible. (The XAMPP demopages are in a subfolder of this folder).


I know, i've used xampp for about a year but now when I tried to come back to it, i can't see any htdocs folder. I've tried installing it to numerous places on the computer but im not getting any htdocs. the website is working look here: http://dreamot.servegame.com .. really strange.. Help please :(
shizumexx
 
Posts: 9
Joined: 30. October 2007 15:46

Postby confused2gether » 30. October 2007 17:04

well for one thing, i'm hoping that you dont have any sensitive data in your mysql db right now since you can get right in since you didnt set any passwords for it yet......
confused2gether
 
Posts: 17
Joined: 29. October 2007 15:48

Postby shizumexx » 30. October 2007 17:06

confused2gether wrote:well for one thing, i'm hoping that you dont have any sensitive data in your mysql db right now since you can get right in since you didnt set any passwords for it yet......


nope it's all default :p
shizumexx
 
Posts: 9
Joined: 30. October 2007 15:46

Postby confused2gether » 30. October 2007 17:21

can you navigate to it manually from the nav bar through explorer? i.e.

c:\xampp\htdocs\

Could you have possibly hidden that file? Seems off chance that would happen being it a fresh install and all.
confused2gether
 
Posts: 17
Joined: 29. October 2007 15:48

Postby shizumexx » 30. October 2007 18:08

confused2gether wrote:can you navigate to it manually from the nav bar through explorer? i.e.

c:\xampp\htdocs\

Could you have possibly hidden that file? Seems off chance that would happen being it a fresh install and all.


oh hey i could access it through the explorer, but how am i supposed to change anything if i can't access the real folder from windows?

It's not invisible, i've enabled show invisible files
shizumexx
 
Posts: 9
Joined: 30. October 2007 15:46

Postby Wiedmann » 30. October 2007 19:21

Hm, sorry, but these sentence from you are totally the oposite:
i could access it through the explorer,

and
didn't get any folder called "htdocs"

or
if i can't access the real folder from windows?

(BTW: what's a "real folder"?)

Maybe you should describe more detailed what are you doing and what happens...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby shizumexx » 30. October 2007 19:29

Ok sorry, i'll try to make myself more clear

Ive used apache/xampp much before, never had any problems. But then I cleaned my harddrive and it was uninstalled, so now I went to install it again, and i downloaded Xampplite. Then I tried to edit the homepage (i already have all the .php files ready), but there was no "htdocs" folder in c\xampp\

So I tried uninstalling and installing in a different place (the desktop), but nothing changed, still I couldn't see any htdocs.

So I started apache_start.bat, and typed in http://dreamot.servegame.com (which is my IP). And there was the demopage.. And it couldn't appear from nowhere.. So I must have a htdocs folder.. and i go to c:\xampp and put "show invisible files and folders" nothing there..

Then i opened Firefox and typed in c:\xampp\htdocs, and this is what happens:

Image

you understand now? I can see the folder in my web browser, but not in my windows.. so i can't change to my own website instead of Demo from xampp...

Hope i made myself more clear

thanks
mike
shizumexx
 
Posts: 9
Joined: 30. October 2007 15:46

Postby Wiedmann » 30. October 2007 19:34

I can see the folder in my web browser, but not in my windows..

A "explorer c:\xampp\htdocs" in startmenu-->run does not work?

You have a similar picture from Explorer with the folder "c:\xampp\"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby shizumexx » 30. October 2007 19:57

Wiedmann wrote:
I can see the folder in my web browser, but not in my windows..

A "explorer c:\xampp\htdocs" in startmenu-->run does not work?

You have a similar picture from Explorer with the folder "c:\xampp"?


yepp i got one here..

Image

as you can see it's not english language but it means that it doesn't exist.

Thank you very much for your fast replies, i really appreciate it, I hope we can get this sorted so i can get my page up, would be great!

thanks again
mike
shizumexx
 
Posts: 9
Joined: 30. October 2007 15:46

Postby confused2gether » 30. October 2007 20:08

I'm downloading the lite installation and I will try to duplicate this. The full version should work just fine though if you use the installer version. Are you getting the install files from apachefriends/sourceforge or some other site?
confused2gether
 
Posts: 17
Joined: 29. October 2007 15:48

Postby Wiedmann » 30. October 2007 20:12

as you can see

Sorry, please use an external link to a bigger picture... (it's to small to read something.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby confused2gether » 30. October 2007 20:16

I just downloaded a fresh copy of the XAMPP-lite zip and when I extracted it, it had the htdocs in the correct spot and its not hidden. Try removing everything related to that xampp folder and any other xampp folders on your computer, stop any services such as MySQL, Apache, FileZilla, Tomcat, and then try running it again. Try and use the full-edition installer and go that route. Also make sure the folder that you are installing/extracting to you have all read/write access.
confused2gether
 
Posts: 17
Joined: 29. October 2007 15:48

Postby shizumexx » 30. October 2007 20:52

Image

here's the picture.

And I tried downloading xampplite from both sourceforge and apachefriends, and guess what, the htdocs folder is IN the zipfile, but when i extract it, everything but the htdocs folder shows when i try to access the folder i extracted to.

So then I tried to drag ONLY the htdocs folder to c:\xampp\xampplite

guess what happened? Nothing. It's like it wont let me access the htdocs folder even if it's there..

So then I extracted ONLY all the files inside the folder htdocs from the zip-file, and that worked. I can touch anything except the htdocs folder..

But it won't do me any good, because if I try to make a folder called htdocs inside c\xampp\xampplite, it says "Folder already exists". Fucking wierd!!

Then I tried making a folder on the desktop and rename it to htdocs. It didn't let me, instead it just removed the folder.. something's up.. can this be a virus?
shizumexx
 
Posts: 9
Joined: 30. October 2007 15:46

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 71 guests