Relative Path in Firefox error - IE OK

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Relative Path in Firefox error - IE OK

Postby tshorter » 18. October 2007 19:47

I have my local host pointed to a top directory where I store my web sites. I enter localhost in browser to get list of directory then select website folder then select program.

I was working weeks like this and viewing (with FireFox) a page with a flash object just fine and then it disappeared. I then brought it up in IE (and the FF IE emulator) and the flash showed up.

I tested with some other test pages and FF worked fine. I realized I had the flash (swf) file in the same directory so I went back to my original program and moved the flash object in same directory and changed the link to it accordingly. It then worked in FF.

It seems FF is all of a sudden not following my relative link but it is OK in IE.

It does not matter whether this is a PHP or HTML page. The same behavior is exhibited for both pages under XAMPP. The HTML page does however work in FF if I bring it up outside of XAMPP.

I am using Object Swap to embed the flash. I also un-installed and re-installed XAMPP.

I am stumped. Any ideas?
Thanks ... Terry
tshorter
 
Posts: 2
Joined: 18. October 2007 19:33

Postby tshorter » 18. October 2007 22:01

Looks like I solved the issue by pointing local host directly to the website directory instead of one level up and choosing the directory.

I still don't know why it had been working in the past however. This is certainly not as convenient.
Thanks ... Terry
tshorter
 
Posts: 2
Joined: 18. October 2007 19:33


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 45 guests